Agent Requires OSX Admin Login?

Mac Technical Support
My children play Diablo III on a Macbook with Parental Controls -- at least they try to. The can not do so if I'm not home.

When you start the Diablo Launcher, the "Agent" program requires admin access -- you have to login as the MacOSX Administrator for the Macbook and give permission for the Agent to do something.

I won't be giving them administrator access to the computer, is there any way I can have the Agent run without admin login every time?
it should only do that when there are updates as far as i've seen, it runs as current user if there is nothing to patch/install.
Thanks, Omega -- that makes sense, just not sure how to fix it. Having to patch every now and then shouldn't be a problem for admin login -- but every single time we start the game is strange.

When you say "it runs as current user" -- do you mean the logged in user of the Macbook, or the user login? Intuit you mean the macbook user....

Hmmm -- I initially installed the game logged in as the admin, MY login. But then the kids go to play logged in on THEIR mac user accounts. And when they hit "Play" we get the "Agent Requires Admin Access to Run" prompt for admin name/password.

Honestly, haven't tried it since logged in as admin -- kids are logged into the macbook and I just take over and play a bit, just a little bit. Wee small bit.
When I used parental permissions I would give permission on individual basis for games. You do this via the "Users & Groups" option in "System Preferences" under the Apple menu.

However there is a problem here. The "Agent" is a temporary application and the system software gives you a dialog box to look up this "Agent" application and you will not be able to find it.

There is a sneaky work around and it will require you to use the Monitor.

It is very possible to give access to the Diablo III folder for every account. I am making the big assumption that "Agent" will be considered to be in the Diablo III folder.

If not then a script can be made. You would change directory to the Diablo III folder via the script and the script would next launch the Diablo III application. Then you are guaranteed to be in the folder! So the kids would be required to launch the script when they want to run D3. You'd keep the script in the Diablo III folder. You can change its icon to the D3 application icon so that the kids don't get confused when it pops up in the Dock. By script I mean a little file that contains Unix commands. I don't mean "Apple Script".

Whenever I play around in the monitor I eventually get it right and I always tread carefully. I cannot just do this off the top of my head like a pro sorry. You'll need someone else to spell it all out for you.


This is a deficiency in the Diablo III installer and not OSX. Blizzard *could* repair this but given the Mature rating for the game (at least here in Australia) they have no compelling reason to fix it. My young kids play too and they are not axe wielding murderers. Yet. :)
Thanks Tara! Hmmm, I almost understand what you're after but am hesitant to play around in Unix.

I did just check -- Logged in the Macbook under my admin account and launched the game.

NO Admin login/password prompt during launch, hit "play" and it goes right into the game.
05/22/2012 06:30 PMPosted by Taraezor
It is very possible to give access to the Diablo III folder for every account. I am making the big assumption that "Agent" will be considered to be in the Diablo III folder.

It's not.

It's launched from /Users/Shared/

As for why it's re-authenticating I don't know. I always play on an admin user.

Agent runs as root for the initial install but after that it should just running as the normal user.

The OP's Agent probably doesn't have the correct permissions/ownership on it.
OP I just logged on the Guest User on my computer and was able to start up the Launcher and was never asked for an admin username and password.

If you like I can guide you through some steps to fix it so your kids can play on their account.
Sure! Thanks!

I definitely saw a "Checking for Updates" progress bar/window right before/after the admin name/pswd prompt from the kid's computer account/profile....

Hmmm, how do I private msg you?
Okay let's start with this :

When logged into your kid's computer account and the window comes up for the admin username/password ....

Can you make a screenshot and upload it somewhere like imgur

Then give us the link here.
I am having the same problem with windows 7 where without an admin account i can't play. Is there a way around it?
just let them watch !@#$ it's going to happen eventually
actually agent's path changes EVERY tools update, it is actually launched from a diff folder every version, that path blu posted i'm not even sure what uses that cause i've NEVER seen it used. I have to approve new rules for launcher and agent every time it's updated. For example, my current rules are for these 2 paths

/Users/Shared/ Launcher.1608/Blizzard

To be honest i'm not even sure why it archives every version of tools, and installs every new version of tools to a new path, it's outright annoying for admin privs and firewall management. Newer version should supersede older version and there shouldn't be 8 copies of same program archiving all the versions. SC2 it makes sense, for replays, but agent/launcher, i have seen no scenario where the older versions are EVER used. Even if D3 updates tools to a newer version than what MoP uses, when i fire up MoP beta, it uses the NEWEST version installed even though it wasn't MoP beta that installed it. In other words, it always ALWAYS uses the newest version, so keeping anything but that is futile, in fact, i further test this by manually deleting the older ones from time to time since they are unused and just a waste of space. :\

Ultimately this isn't a mac team design though, tools is a separate team from mac or windows.
I'm having this exact same problem. But different.

Game runs fine I'm using the original installation account (an admin account).

But every time we try to run it from another user account on the same machine (no parental controls, with or without admin privileges) the game will prompt "Agent wants to make changes…" and then hang following that.

Same thing here. I installed the game from a user A account, then Agent prompt for a password when I run the game from user B.

Not a big deal but it would be great without that.
I am having a strange variation of this error... I am playing ON the admin account and it still prompts me to give a password each time (I don't think it's associated with updates).
I believe it happened after I changed the password on my account, so I tried the following:
- repair disk permissions/restart
- reset keychain/restart

These solutions did not work permanently. However, one time I tried repairing disk permissions, it solved the problem for one occasion before the problem continued as before.
The solution to my problem as found here:
Simply remove and re-add the dock icon after each patch...

This leads me to believe that my problem was different than the one in this thread, but thought I would share my solution
It happens every time I launch diablo - I get the same message. I found that if you hit "Cancel" it skips the admin osx authentication and gets you to the "Play" button on the launcher.

Not perfect but it works - especially if you have kids that want to play it.
I hit cancel - it sends me to an error message and ends the program. I launch the launcher again and it works without having to do admin login. Odd bug.
If it's prompting you to enter in your admin user name/password this means something is attempting to update, D3, Agent or Launcher somewhere.

The solution to my problem as found here:
Simply remove and re-add the dock icon after each patch...

This leads me to believe that my problem was different than the one in this thread, but thought I would share my solution

This is happening because instead of putting the launcher shortcut, you are actually putting a specific version of the launcher and/or game on the dock.

If you wish to perm stop this, simply remove any D3 icons from your dock, then go into /Applications/Diablo III and drag the Diablo III launcher to the dock. This is a universal shortcut that will always adapt to the latest patch.
Just did that and it still prompts for sysadmin authentication. I typically launch d3 from spotlight but now tried the proposed solution "the launcher from the said app folder" to no avail.

Perhaps others have had success doing this?

Join the Conversation

Return to Forum