Auction House Problem

Bug Report
I just tried to buy a piece of armor on the auction house 5 minutes ago. It said that the process timed out; but it still took my gold. What gives?
I'm with you there, bought a sledge fist then timed out. I can see the transaction number and all. but it says failed at the side. it took away around 50k of my gold. :( but i got nothing.
Ah is all messed up. Wonder if it cant handle the load.
I hope they're able to remedy this and at least return the gold....
I might not want the money back, rather, that specific item that I bought with the exact stats I got it for.
05/26/2012 09:56 AMPosted by potatobear
specific item that I bought with the exac


you may be asking for too much...
Same here, I lost 200k g :S
Does tech support typically even respond to these threads?
hi i also got the same issue.. and it happened to me twice already?! is there a way to resolve this? or at least get back the gold?? cause its not easy to earn the gold..
Lost gold here too.... i have a failed transaction on my transaction log.
Hi, like to report the same problem at the exact same time that the first poster.

Prior to this, the error given was that the auction house was not able to find my payment details.

After pressing the buyout button and confirming, the dialog box stated that item was sold/no longer available/buyout timed out.

This happened with 2 different items.

I got out of the auction house, then went into the auction house again. I rebid on a third item - at this point, my balance reflected that I had not had funds deducted.

When I bid on the the third item, it was rejected for lack of funds.

My auction house stash now contains the "bought" items - however, I am unable to send these items to my stash. The money remains deducted. The items remain unusable.

May I suggest that you delay the rollout of the RMAH until the auction house works smoothly? People are going to be very, very upset if you deduct a couple of hundred dollars out of their paypal for items that do not exist.
Also, cant list anything for auction now. Giving Error 317###.

Has also cancelled a number of my auctions from this morning, atleast it sent me the items right back. CMon guys, get your act together and finalize the Auction House.
this just happened to me too -_-
Strange that there is no verication on client side to deduce if the transaction succeeded before deducting the gold... duh
Feels like a rollback for all transacted accounts should be in place
I logged out with 10 items for sale, I came back with 6 for sale, and 1 ended auction in the completed tab. When I switch from a HC to SC toon, I still see the same ended auction in my completed tab. Haven't clicked 'send to stash' to see what happens yet.

Yesterday, I bid on a yellow item, and it timed out. So I bid again, and it accepted. Then go and look, and the auction is exactly at my own max bid, and I also have a refund for being outbid. So despite the first request timing out, the AH accepted the bid and took my money, meaning I drove up the price myself with the 2nd bid.

Please fix the AH.
Bought 300k shoulder off the AH, request timed out. 2 minutes later the AH goes down, and when it came back up no shoulders and down 300k :(
same stuff is happening to me too. keeps saying the items are no longer available or timed out so i go to the next item i want. log out come back in and there are the 4 gloves i tried to buy in my completed tab..... >:(
+1 on this.

Buyout, timed out, took my money. Loss of about 350k
Had something similar happen to me (Though not as severe as others). I went to buy a weapon for 10k, request times out and when I refresh, the item is sold. No big deal, I just looked for a new one (Since my log doesn't show me buying it). I went and tried to buy a new one (Same price, 10k), says it's processing, and eventually that went through. I got that one in my completed tab and everything.

But I noticed something.. I ended up getting 20k taken away from my funds. Now, if I was to actually GET the first weapon, I wouldn't have cared, I could have just sold one of them off. But to have gold taken for something I wasn't even able to purchase, is a bit frustrating (As it's not the first time).

keeps saying the items are no longer available or timed out so i go to the next item i want. log out come back in and there are the 4 gloves i tried to buy in my completed tab..... >:(


Also have had this happen to me.. Keep getting failed purchases, so I try again.. Only to find out that I indeed purchased all of them, and they all show up in my completed tab later on.

Now, I'm not one to complain or QQ, but this AH nonsense is getting rather ridiculous. How did this buggy-as-hell junk make it to live? Was this not tested and fixed up during the beta? :P

EDIT: Just had something else happen.. Bought something, it went through.. Went to my completed tab, and when it refreshed, my item didn't show up; It cleared out my entire list, and now it's blank. Ugh.

Join the Conversation

Return to Forum