Mac Launcher Stuck On "Checking For Updates"

Mac Technical Support
So I was able to get in the game and play for a long time, say 12-14 hours worth. I even logged out and back in, but now in my most recent attempt to get in game I am completely unable to. The launcher gets stuck for a very long time and is unable to launch.
same probem for me
exact same thing played 12 hrs~ rebooted my comp and now checking for updates is not loading at all (patch service is not loading .. for wow too)

i have all the proxys disabled and stuff, still not working... and there is no response anywhere for months
Bump same here, I have full access through my work firewall as I'm the sysadmin :)
I've seen posts on here saying download this patch from this site and frankly I'm not downloading a patched mpq file from some site that isn't blizzard. Nor should I have to.

Be interesting to see if I get the same problem from home, I played at worked for over an hour in my lunch break yesterday with no problems.
i hate you blizzard, my friends beat the game without me because of this !@#$. i mean, we get online games so we can enjoy the game together with friends. now i can't hope to catch up because the precious time i did have to play this game was wasted on trying to figure out wtf was wrong with the game. basically, fix soon plz
Have you tried deleting your Battle.net folder in Users/Shared and see if that helps?
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...
Same thing here. Ive deleted the battle.net folder but then it just gets stuck at "updating setup files." Weak sauce...
Has anything happened to fix this? I have been playing fine since launch and now out of the blue Diablo III Setup is stuck at "Updating setup Files..." I've trashed the Battle.net folder as suggested with no effect.
05/24/2012 03:00 PMPosted by Hawke
Has anything happened to fix this? I have been playing fine since launch and now out of the blue Diablo III Setup is stuck at "Updating setup Files..." I've trashed the Battle.net folder as suggested with no effect.

There was a tools patch released today, which I believe it is attempting to grab.

Have you tried optimizing your connection troubleshooting located on this article?
Totally ridiculous! We buy a game that we expect to WORK. Something that Blizzard does makes it NOT WORK, and somehow WE are expected to fix the problem?! Utter crap if you ask me. The game worked fine, Blizz did an update and now I have a non-functional, worthless game. And the REAL rub? I am expected to tinker with my computer settings to fix their problem. Sorry, Blizzard but that is not a sufficient response.
So if the problem is at your end, you expect blizzard to fix it by coming to house and doing those steps for you? Any number of connection probelms can cause the issue.

For example, do to a bug in my routers firmware (to no fault of blizzard), My internet disconnects any time my upload bandwidth exceeds about 70% of it's max threshold. Unfortunately launcher is designed to have p2p enabled by default, and worse over, it cannot be turned off until AFTER you've gotten passed "updating setup files". This caused an infinite loop of disconnects and failed updating for me. Until i created my own fix for p2p issue. Maybe your issue is similar, you should try some of steps here to see if any of them help, including using my agent.db file to force disable p2p before you fire up launcher and see if it solves problem.
http://us.battle.net/wow/en/forum/topic/4511762211
First- thanks for your reply MysticalOS, for sharing your own experience and providing the link. l sincerely appreciate the help.

Second- no, I actually don't expect them to come to my house and fix the problem if it's on my end. I didn't mean to imply that. What I'm expressing is that I've already spent hours trying to resolve any issues that might be on my end, not to mention having to reinstall the digital copy several times just to get the game to work again.

Truth be told, I've spent more time fiddling around with my computer and researching potential solutions to various problems than playing the game. Thus, the frustrated rant above. I'm perfectly willing to be responsible for solving problems that are on my end. However, I'm frustrated with the amount of time I've had to spend doing so, particularly because I'm not certain they've all been problems on my end.

In any case, after more hours tinkering with my computer and further research I finally just reinstalled the game again for a 3rd time out of frustration and once reinstalled, it is inexplicably working.

Posted this bit on another thread. It was part of a longer post which I subsequently deleted because I'm not inclined to be ranting on the forums. Actually came here to delete this one too until I saw your response. Quite honestly, every fix that I've had to use thus far to get the game to run properly has been offered by community members like yourself.

Thank you Community!!! You folks are truly wonderful!
my !@#$ing thing still doesnt work i did literraly everything i could and it %^-*in doesnt work i disabled proxy changed the port deleted battle.net it !@#$ing retarded
hi, i know it's a bit old but i have the same problem recently
on my mac and I try to delete
battlenetaccout.URL,
d3debug.txt and
launcher.db
then I was able to log back into d3. thanks.
can anyone do something here? still not working
SAME HERE AND SO PISSED!!!!!!!!!!!!!!!
i did all the steps and im still stuck at this problem
The reason why this problem occur. You probably have the test realm client installed asswell.

Delete the d3debug.txt in the general Diablo 3 and the Diablo III Public Test folder.

Done..
Frank123, there is a sticky at the top of this forum for patch day issues here:

http://us.battle.net/d3/en/forum/topic/8769297767

Scroll down to the section labeled Stuck at Initializing... and follow the instructions there. They are the same for the "checking for updates" problem you are having.

Mockingbird: Deleting the D3debug.txt does not solve any problem as that is not a file that the game reads from, but instead writes to. In fact, deleting it could wipe out some potentially critical information used in troubleshooting. It it advised to not touch that file unless asked to by an MVP or tech support agent.

Edit: Also, please don't necro old threads. If you have an issue, post in a new thread so we can help you properly. This thread is a year old.

________________________________________________
Diablo III and World of Warcraft Technical Support MVP
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.

Join the Conversation

Return to Forum