Still stuck on Updating Setup Files

Technical Support
I bought the game this morning and left for work when it was Updating Setup Files for download. I came back home and it was stuck in the same place. I searched online for the fix and have done all of the following, but it still gets stuck when it's almost done (looks to be 95-97% complete):

Secondary Logon started* (set to auto start)
Deleted C:\ProgramData\Battle.net
Deleted C:\ProgramData\Blizzard Entertainment\Battle.net\Cache
Set exe to run in compatibility mode (Win XP SP3)
Rebooted
Running exe as administrator

I still can't get past this initial Updating setup files. WHen I close it out, I get the following error:

Exe: C:\ProgramData\Battle.net\Agent\Agent.954\Agent.exe
Time: May 15, 2012 6:04:58.058 PM

------------------------------------------------------------------------------

This application has encountered a critical error:

ERROR #1 (0x13370001) Fatal Exception
Program: C:\ProgramData\Battle.net\Agent\Agent.954\Agent.exe
Exception: 0xC0000008 (INVALID_HANDLE) at 0023:77CA27B8
The only thing that worked for me was to use this guys files:

http://www.gamefront.com/files/service/thankyou?id=21699449

That's not to say that I didn't have 20 other errors and problems afterwards. I'm still unable to play and have been as far as 99% updated with the play button becoming pressable...
Thanks for the reply. I was able to get it to work. I again deleted:
C:\ProgramData\Battle.net
but this time, instead of just the cache, folder, I deleted:
C:\ProgramData\Blizzard Entertainment\Battle.net\

I then started up Starcraft2 to recreate the folders. Exited SC2, ran the .exe as Administrator and it finished pretty quick. Now on to the install. Hopefully the rest goes smooth.

Sorry to hear you're having such a hard time.
i have done everything, multiple times now, the updating bar is stuck under the n un updating it was at 90% then went back down after i decided 2 hours at 90% is long enough, funny thing is, it worked on my friends macbook in around 30 seconds,

so im wondering WTF BLIZZARD! is there any way to download a file that covers the setup files?

Join the Conversation

Return to Forum