Starter Edition won't upgrade to Standard

Mac Technical Support
Prev 1 2 3 4 6 Next
Pretty much same problem with me D: I haven't given it 72 hours yet but it still says that i have a standerd edition. I can access the auction house. But i just cant get pass the Skeleton King..... Please Blizzard sort this out fast! It seeems from the other complaints that you haven't don ANYTHING in the space of a week or more.... Pathetic Customer Service by the sounds of it!
I suppose it doesn't purport to, but patch 1.0.3a doesn't fix this problem. :(

http://us.battle.net/d3/en/blog/6514995/Patch_103a_Now_Live-6_26_2012
http://us.battle.net/d3/en/forum/topic/5889161030?page=5#98

You sure it's not fixed? you are patched up and game version definitely says 1.0.3a? (keep in mind it is only just now live in EU and only Us had it earlier today).
________________________________________________
Mac Tech Support MVP
WoW Addon Author - http://www.curseforge.com/profiles/mysticalos/
Hi MysticalOS,

I'm in California so I was able to patch before I posted that 1.0.3a doesn't fix my problem that I posted earlier in this thread:

http://us.battle.net/d3/en/forum/topic/5150755821?page=2#38

I'm starting to think that I should just roll the dice, and find out if overwriting my currently saved progress will require me to defeat the Skeleton King again.

Thanks in advance for any advice!
The patch fixed mine no problem. The game started me at the beginning of the "Reign of the Black King" quest. Once I beat the skeleton king again, I was able to continue the game. Beating the skeleton king again was.... how do I say this... familiar? Anyway, my game is working fine now. Problem solved. Saves me the trouble of calling and requesting a refund. Thanks, Blizzard.
NakAttack, It doesn't delete you game. Just start from the "reign of the black king" quest, "this will overwrite your previous game"... okay, and enjoy moving on in the game.
Ah, so if you resume off an old quest it uses start edition still, starting over from quest will get it working again, good to know.
________________________________________________
Mac Tech Support MVP
WoW Addon Author - http://www.curseforge.com/profiles/mysticalos/
what you have to do id go on the diablo 3 page, click 'buy now' then on the page, you will se 'redeem key' put in the new key from the standard edition you have just bought and wil say you have upgraded from starter
hi,
im french sorry for the english
i got the same problem as op ,i resolved mine.
i deco from the game
i used battle.net i changed my password and i relog in game
and it was ok at this time.
i think it is a problem with gamecache on battle.net server you need to refresh it by a way or another.
so if you got the problem try it,and good luck
bye
I upgraded from the Starter Edition and have been waiting the three days for the game to upgrade, but two days ago I received an email from Blizzard saying my "payment has successfully processed and your account now has full access to all game features"
But two days after that, the game is still only a Starter Edition! Will it be much longer, Blizzard?
All in all Blizz needs to shape up or lol "Ship out". I have the starter edition and am lvl 30...how you ask? No clue. My husband has the standard edition and he's still playing. We both bought the annual pass from wow and got the copy of D3, yet here i am stuck with the starter copy and hes got the standard..what gives? Maybe i misread something...seems strange to us. Anyone else with a similar problem?
I tried The Version of D3 then updated file not work for full version and still got "update now banner " then i realized what is going on. install Diablo 3 by DVD with dvd box with serial code.....

finally i fixed it by myself :)
Same problem here, please quickly fix it.
Are you able to try again YiSgeng003 and see if the issue persists?
hi guys! ive had the same problem here and i have been waiting for a week. i also sent an email 3 days ago but no reply from blizzard yet! so disappointed. can anyone help me to fix this problem. i tried install the game many times, tried to resume off the quest many times, but nothing is different... thank in advance
This mainly can be resolved with a password reset. Can you try it out and see if it works?
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
what about people like me who bought a box set with a game key? It's been 3 days since I key in the game code and still unable to play. The UPGRADE banner still on the top right of the screen. It is so frustrating...

When i check the account management, it is standard edition, but when i start the game, everything back to the starter pack. Can someone please help?
i reset the password, and funny thing happen...

When i log in to Battle.net here, I need to use the new password. But when I start the game, I need to key in the old password and back to the UPGRADE page, otherwise, it will tells me "Error 3". What kind of bug is this? I can't do anything proposed here.
This mainly can be resolved with a password reset. Can you try it out and see if it works?
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? [url]https://battle.net/support/article/contact[/url]
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!


It won't work for me, really piss off. Need help here...
Hey Artemis,

This looks like it was resolved already. Let me know if this is not the case.

Join the Conversation

Return to Forum