Music keeps restarting...

Technical Support
Hey guys, I'm having this really annoying problem where the in-game music keeps restarting randomly. The game stutters every time this happens but the weird part is some times I will be playing for a while with no problems and at other times it seems as if every 5-10 seconds the music of the current area (either in-game or in the menus) restarts and is also accompanied by hiccups/game stuttering. Any ideas?
shameless self-bump
bump help please
Also cinematics are cut-short... any ideas?
I am having the same issue.
I'm having the same problem as of yesterday. I hadn't played the games since the last patch until yesterday and that's when I started having problems.

Using a Mac. I also updated to Mountain Lion, but doubt that has anything to do with it.
Seeing as how this hasn't been addressed thus far I'm guessing it won't be. If either of you found a solution then please let me know, it's really irritating.

Quest dialogue is even getting cut off when the followers talk, and not from clicking out of it. It's like all sounds get reset. Possible sound card issue? Might as well just turn everything down and listen to diablo II music.
Having the same problem. I'm also on a mac running 10.8.2
Me too. 10.8.2. Music restarts about once every 1 second. In the menus as well. Launching into the game works, but it stutters every time the music restarts (about once a second or faster). Unplayable this way, what's going on? It was working when I last played (August?) but then I played again today for the first time, DL'd ~145 MB update, and now it's broken.
05/16/2012 07:30 PMPosted by haigo
Hey guys, I'm having this really annoying problem where the in-game music keeps restarting randomly. The game stutters every time this happens but the weird part is some times I will be playing for a while with no problems and at other times it seems as if every 5-10 seconds the music of the current area (either in-game or in the menus) restarts and is also accompanied by hiccups/game stuttering. Any ideas?


Exactly the same thing over here...

Sound restarts accompanied by a super stutter... Really negatively impacts the experience.

Problem started with 1.08.

I also can play for 15-20 minutes alone and not have it happen, but as soon as I play with a group of 3 it happens almost instantly.

I have a feeling it has to do with a specific sound playing, or when too many sounds trigger at once, overflowing the buffer.

Not really sure, but it is a new bug -- not a hardware issue.
same thing, music will start to play, then game starts to skip hard, then music goes to a new song or starts over.

the game stutting is what i want to fix, the sounds not a huge issue. it stutters hard enough to hold off on my hardcore chars, and thats not cool with me.

this post is old, back in 2012-13, but i couldnt find a fix through the forums or blizzards tech search. I hope i'm just missing the post?

edit: ive tried turning off my music in game and it still happens. tried turning off sound and music both and it still happens too
have you tried to remove shortcut to enable/disable music ?
go to option, locate enable/disable music, pick any key that is currently in use for an other option, then go to the other option, reset to its original key.

Join the Conversation

Return to Forum