D3 Running SLOW on GOOOD MAC

Technical Support
Hello. My system specs are as follows: 2.2 GHz Intel Core i7, 8GB RAM, Graphics: AMD radeon HD 6750M 1024 MB on a MacBook Pro 2011 late edition.

I am running the game with NO EXTRA EFFECTS and all textures off, graphics at lowest possible! lowest resolution!

the game runs fine in the beginning of every startup (still slower than i seen it run normally, but playable) but a little into the game, when i run into monsters it slows down to give me a matrix style gaming, SLOW as hell! when it picks up speed, it looks the computer took a steroid and everything moves extremely fast (this is rare)... it usually remains slow for the duration of the game.

I recently FORMATED my mac, reinstalling a clean version of Lion, specifically to run D3 to the max! It did not help much.

Is this my Computers fault? Blizzards fault? is there anything I can do or just wait for an update?
Wrong section to be posted should put it on the MAC forum.
Clearly your problem lies in thinking that a Mac would be a good gaming machine :(
are you on wireless ? macbook pro would suggest yes
why dont you connect your mac directly to your router? it helps on reducing high latency
05/22/2012 03:31 AMPosted by Kittahsmash
Clearly your problem lies in thinking that a Mac would be a good gaming machine :(


LMFAO....epic just epic...you beat me to it.
...GOOOD MAC...

...there is no such thing
I'm experiencing the same problems. Connecting to the router doesn't help. Latency isn't the issue. The game played fine for a week, so the hardware problem the PC fanboys suggest isn't the issue.

I even tried all the suggestions Blizzard posted here:
http://us.battle.net/support/en/article/diablo-iii-running-slow-or-choppy-mac#5

I'm going to try uninstalling/reinstalling.

We just need to wait for Blizzard to fix the problem and distribute a patch.
I have a macbook a little older then that, and it runs perfect on high settings.
Mac guy here. I believe I have the same system as you do.

Here's the way I run it, and it's pretty smooth:

  • Windowed mode (mainly for text sharpness)
  • Antialiasing: off
  • Physics: low
  • Sound channels: low
  • Shadows: off
  • Textures: high
  • Everything else is medium


Also, I shut down Firefox/Chrome and Mail/Skype. These apps are constantly pinging other servers and generally are a nuisance. Also, Firefox is a damn memory hog and affects my game pretty badly.

Hope this helps.
This is a known issue and is "being worked on." Your Mac, (I have the same one) is fine (certainly better than any PC) and I've never heard of such limitations. I've been able to run much more intensive graphic and FPS games on the laptop with no problem. This is only solvable with a patch.
http://keremkoseoglu.wordpress.com/2012/05/22/diablo-3-slow-on-mac-here-is-a-solution/
Try dropping the resolution and capping frames at 30, did that for mine (old !@# base model 2007-8 desktop) and even on the resolution below max it doubled in speed, while on a similarly geared window comp (at work :D) I had to drop it to base 800x res.
Try it and see if it works!

edit: didn't bother to read any other posts than main, in a rush. Might be duplicate.
yea diablo is pretty terrible on mac, like most games, just buy a pc
I'm a windows 7 user and you guys all sound like crazed windows fanboys (windows is pretty trashy).. Blizzard is notoritous for making their games windows/mac.. And they do a good job. There's obviously some compatibility issues across the board right now (mac AND windows).

I am having a similar problem on my Sony VAIO (WINDOWS 7).. tons of people are having performance issues.. we just need to wait until Blizzard figures it out.

And if any of you knew anything.. the system on the Macbook Pro he just posted should be able to run Diablo 3 on max. ( Stop trollin)
lol ur video card is 6750m mayb thats why.
just boot camp it. macs will never be good for gaming
08/11/2012 03:20 AMPosted by coco
lol ur video card is 6750m mayb thats why.


I have a 320m integrated card and running max settings on my macbook pro (on windows)

keep your uneducated comments to yourself

Join the Conversation

Return to Forum