Getting stuck at the loading screen

Mac Technical Support
After clicking on the 'Resume Game' button, D3 gets stuck at the loading screen. After a few minutes I'll get the 'Game Connection has been lost: your client has been disconnected from the server'. D3 freezes on this error and needs to be force quit.

However, if I use Hotspot Shield which provides a free VPN service, the game loads fine but is noticeably more laggy with a ping of about 600 - 900 msec.

I only started encountering this problem today, D3 was giving no problems before that.
Any help on this would be great.

I'm running Mac OSX 10.7.4 and I've tried both wireless and connecting directly to the router but it won't work unless I use Hotspot Shield.

D3Debug.txt shows the following error when I try without using Hotspot Shield.

BnetParty::CloseStatusChange_SetPrivacyLevelCallback code=0 old=CLOSED(1) new=CALLTOARMS_MUTUALFRIENDS(4) reason=CREATING_GAME(0)
2012.05.20 19:17:49.336811208 -----------------------------------------------------------------
2012.05.20 19:17:49.336958963 Server Version Information:
2012.05.20 19:17:49.337840838 -----------------------------------------------------------------
2012.05.20 19:17:49.338047715 Server BuildVersion: 1.0.1.9782
2012.05.20 19:17:49.338416552 Server SNOPackHash: 0x23B65EEB (client hash = 0x23B65EEB)
2012.05.20 19:17:49.338684923 Server ProtocolHash: 0x33CABB38 (client hash = 0x33CABB38)
2012.05.20 19:17:49.338948978 -----------------------------------------------------------------
2012.05.20 19:24:19.505837388 recv() failed: Conection timed out.
2012.05.20 19:24:19.505963619 ClientSocket Disconnect
2012.05.20 19:24:19.506819769 UIStartup_ClientDisconnected msg=The game connection has been lost: your client has been disconnected from the server.
2012.05.20 19:24:19.507196837 >>> Leandra ===== Battle.net SetD3GameServerDisconnected ===== The game connection has been lost: your client has been disconnected from the server.
This error has been happening to be constantly for the past 2 days.
need help same issue
i have the same problem
Can you try deleting your Battle.net cache and see if this helps with the connection issue?

Clearing your Battle.net Cache
    1. Navigate to Mac HD/Users/Shared/Blizzard/
    2. Move the Battle.net folder to the trash.
    3. Empty the Trash.
    4. Launch Diablo III
It didn't work for me
I have the same issue.
What i have done is:
1. delete Battle.net folder
2. checking and setting permissions of the D3 folder to rwx
3. delete the D3 installation like described in this forum
4. new installation of the game

Issue still persists
Log message: "Disposing UI for World" and after this "ClientSocket Disconnect"
Have you tried logging in from another location and see if it helps? The original post stated this was location specific.
How is it location specific? it's happening to players all over the world, all which need to resort to using Hotspot Shield to bypass this problem which results in lag.

Why is there no direct answer from blizzard? everything regarding this topic is vague and we continue to be bugged by a game that can't even be played single player...

solve this already!
Location specific as in it doesn't work in one place, but works in another. This means that it may be an issue with the ISP or backbone network.

But the question remains, have you tried an alternate location to see if it helps? If it does, then this means it can be narrowed down to specific ISP/backbone networks and then it can be troubleshot from there.

I haven't seen a wide spread report of this issue, so we'll have to narrow it down to fine tune the root cause.

Join the Conversation

Return to Forum