Changing shadows to high caps fps to 30

Bug Report
When I enable high quality shadows, my frame rate is cut in half. This did not occur in the beta.

I have noticed this in Caldeum, and Bastion Keep's stronghold.

Add that to the list with micro-stuttering due to lack of pre-loaded assets (now I appreciate loading times more than ever.) a virtually non-functioning AH, and cinematic video stuttering. On the positive, latency is starting to normalize though.

Cool Easter Eggs, team.

ASUS M4A78T-E, latest bios
Phenom II X6 1055T @ stock 2.8ghz, turbo mode+unleashed mode on (off did nothing)
4 gb ddr3, 535mhz ,7/7/7
NVIDIA GTX 570 stock, latest 301.20 beta drivers
Audigy soundblaster gamer II, latest drivers
1 TB HDD.

Playing in selective startup, aero disabled @ 1080p.

I don't care as much about high quality shadows than I do about stuttering in every area; saying it only happens when something loads for the first time does not negate it as a serious issue: how often or long does one hang around areas they've already explored? It's okay-- take your time.
I'm experiencing the same, and I can't even tell a noticeable difference between medium and high. I feel like maybe high is doing some ambient occlusion type thing? I really can't tell though. At least not without a comparison shot.

Join the Conversation

Return to Forum