Patch required and Game is up to date

General Discussion
Hi, haven't play diablo3 for a while due to it's error.

Just check back and can't play the game.

While login it said "Pated required" said it'll auto restart and do the update new patch.

It back to "Game is up to date" and go around never end.

Anyone got the same problem?

This is diffinitely hell of earth Diablo 3.
I met the same problem``anyone help?
ok, then it not normal because not just me

wait for the blizz team to fix.
me too
me 3
blizzard team did a good job making a bad impression for patching
delayed and now patch fault
Same problem, anyone found a fix yet.
http://us.battle.net/d3/en/forum/topic/5152415037

This link may or may not be of use to you, if you're having trouble updating a non US client to play on the NA servers.
Yeah that's work for NA and EU now just want to confirm,
but too bad its not work for Asia server cause I'm using 'Language: English'.

Should I download 'language: Chinese [Traditional]' 2.2 GB ? ....
http://us.battle.net/d3/en/forum/topic/5152415037

This link may or may not be of use to you, if you're having trouble updating a non US client to play on the NA servers.


Hmmm I tried that and it will now let me into the US servers but not the asian ones.

Guess I will have to change characters.

Thanks Zex
The same is for me. Cannot start the game.
Same here, has anyone noticed if they've already fixed this?
WOOOOW I FOUND A LEGENDARY ERROR ITEM : "THE PRIME EVIL" STATS: "ERROR 1" - CANNOT CREATE UR OWN PARTY +32. EMAIL ME FOR PICTURE
Same problem. Blizzard fail yet again. Nothing we can do about it, and you can be sure as hell they won't either - not in any kind of hurry anyway.

Another few days of not being able to play a single player game I've paid money for. This is why people pirate things.
i hate this game, nothing but problems. 3 days of getting patch problems, i can log in play for 30 mins. next time i log in says i need to patch the game, reboots and asks for the patch again. it just loops over and over until a day or 2 later it will just work. bring on torchlight 2, that game will be 100x better then this crap.
Fixing the issue;
1. open agent.db in notepad
2. change http://enSG.patch.battle.net:1119/patch to http://enUS.patch.battle.net:1119/patch

You will see two places for the address one had correct enUS but the second one down had enSG

The singapore server has not got the patch update as yet and the client tries to download from there.

Mine now running perfectly after this simple change.
Same problem. Blizzard fail yet again. Nothing we can do about it, and you can be sure as hell they won't either - not in any kind of hurry anyway.

Another few days of not being able to play a single player game I've paid money for. This is why people pirate things.


blizzard makes a server based single player game in order to prevent pirating, yet half the time we cant even open the game. and they wonder why people pirate, maybe if they made a game that works properly people would stop pirating.

blizz never fails to dissapoint. proven once again
Same problem here, just tried to play and got Patch required notice, Tried to follow the on screen instructions and i can't get the patch. Just get a message saying Game is already running...... Tried this several times with same result...Not Happy Blizzard
Solved for me:

Added this to C:\Windows\System32\drivers\etc\hosts:

# us.patch.battle.net 12.129.206.133
12.129.206.133 enUS.patch.battle.net
12.129.206.133 esMX.patch.battle.net
12.129.206.133 ptBR.patch.battle.net

# eu.patch.battle.net 213.248.127.133
12.129.206.133 enGB.patch.battle.net
12.129.206.133 deDE.patch.battle.net
12.129.206.133 frFR.patch.battle.net
12.129.206.133 itIT.patch.battle.net
12.129.206.133 plPL.patch.battle.net
12.129.206.133 esES.patch.battle.net

# kr.patch.battle.net 121.254.200.133
12.129.206.133 zhTW.patch.battle.net
12.129.206.133 koKR.patch.battle.net

# sg.patch.battle.net 202.9.66.78
12.129.206.133 enSG.patch.battle.net


Changed all instances of "http://****.patch.battle.net:1119/patch" to "http://enUS.patch.battle.net:1119/patch" in C:\ProgramData\Battle.net\Agent\agent.db.

Sussed.
05/31/2012 04:22 PMPosted by Kursa
Same problem here, just tried to play and got Patch required notice, Tried to follow the on screen instructions and i can't get the patch. Just get a message saying Game is already running...... Tried this several times with same result...Not Happy Blizzard


Hi, I also having the same problem as you. Not happy with Blizzard..

Join the Conversation

Return to Forum