Stuck - Can't Click on Cathedral Level 2

Bug Report
I just got to Nightmare difficulty and am in the Cathedral Level 1. When I reach the door to Level 2, there's nothing to click on. I see the red exuberance pouring out of the door like it's active, but no matter where I hover my mouse I can't get the click-area to appear to move to Level 2, which obviously prevents me from continuing.

I've tried going back to town and returning. I've tried leaving the game and getting back there again. I've tried relaunching the game entirely. All to no success.

I've never had this happen before. Either I'm missing something obvious or I need some help.

Okay, so I found out how to solve this problem.

First, what I think the problem actually was: I think what was happening was that I got the checkpoint for when you drop down into the Cathedral Level 1 from outside and then left the game in Level 1. A server blip must have happened during this time period which made it so that the fact I made it to Level 1 never registered on my character. So the checkpoint was registered, but not the quest data.

So I would spawn in Level 1 and find that the door to Level 2 wouldn't be clickable. What I did to solve the issue was to immediately go back to town, use the last waypoint available (Old Tristram), and walk my way all the way back to the entrance to the Cathedral, drop back into it again, and THEN go to the Level 2 door. This time is was clickable and I moved on.

I can't see how this could have happened except due to an odd server-side synchronization error. The quest data got out-of-sync with the checkpoint system. With improved error handling in this situation, I think this problem can be made obsolete.
After four years this post helped me a lot, thx man :)

Join the Conversation

Return to Forum