"Failed to Update Tools"; Getting Frustrated

Technical Support
So I come home from work and all of a sudden Diablo 3 will not launch. The launcher comes up but the button is all greyed out and it just sits there. After a few minutes it says that it failed to update tools and closes out. The weird thing is that the game worked 6 hours prior before I left for work. Did something change today that I don't know about.

I found some old fixes, generally downloading patch files from http://patchup.info/d3/tfil/NA/. These fixes from this site no longer work. Is anyone else having this problem? And if so, were you able to fix it? A blue post would be especially helpful, since I suspect that the problem lies on their side since every other online based game that is installed on my PC still works perfectly.
Do you have a third party firewall? It might be blocking Agent.exe. McAfee loves to do that.
Delete ur mcafee Internet security if u have it...I tried fixing it for 2 hours going thru all the possible fixes on everyone's post then I deleted mcafee and booom I'm online
I have the same issue, just sitting there. I was getting on last night but kept getting error 3003 when I logged on

now this? I cant see how Mcafee suddenly is the issue after playing this the night before without issue.

AJ
My wife had been playing this game fine then all of a sudden she said she got "failed to update tools" error. I checked the McAfee firewall settings and the Battle.net Update Agent somehow got changed to "blocked". I gave it access and all was well. Check your settings.
Well, I get this error nearly every day... Literally! It has nothing to do with Mcafee, because I don't use it. My internet firewall is turned off, I checked the settings and everything from Diablo 3 runs perfectly, nothing attacking it or stopping. I try to run the game again, still nothing.
Sometimes the only way I can actually get the game to open is to run the diabloiiisetup.exe file from the download, or from the disc.
Even then it takes me like, half an hour to an hours fecking about before it will even allow me to press play, and then after that, it constantly logs me out, or loses it's connection.
I am really get pig sick of this now!!
I use an IP blocker for various reason and it was stopping me from logging on...

Just thought i'd mention it in case you skipped over that kind of sowftware! ;)
Hey, posted the fix that worked for me in this thread;

http://us.battle.net/d3/en/forum/topic/5594216024?page=1#17

Good luck :)
Thank you very MotherF*****G MUCH !!!!!!!!! I whas a second away from destroying my Laptop hahahaha

Join the Conversation

Return to Forum