Wont start

Technical Support
Hello, My problem is when i start the Diablo 3 launcher it lets me click play, it has Diablos head show up in the middle of my screen, but when it dissapears nothing happens. When i try to restart the program, it says " Diablo 3 is already running". I dont know what to do, This diablo experience has been nothing but problems.
same issue
same its mad annoying
Hey I just got mine to work.

What I did was before pressing Play (after it downloaded or initialized or whatever) I closed the launcher, went to Task Manager and closed the Agent process and the Launcher Update process and then reopen the launcher and it worked. Im guessing its opening 2 instances.

You may need to delete the latest MPQ files in the Diablo 3 folder under Updates.
this is happening exactly as OP says for my friend and deleting the latest mpq file did not help.
Hi Im having the same problem, did you get it sorted?
I am having the same issue. I sent a tech support ticket, but searching here for answers. I'm trying to solve the issue for my hubby (his game...he's Mr. Beefy). We had to install a 2nd video card.

I click the icon, click play, shows Diablo III demon head, then nothing. When I click on icon again, it tells me the game is already running.

It is currently running right now. Short of shutting off computer, I have no way of turning it off. I tried Task Manager...it's not listed on there.

I have both video cards hooked up to my monitor. (We had standard card with blue connector, had to get one with the white connectors).

I hope somebody has an answer and soon. I was hoping to surprise my hubby with a working game. (He didn't realize we had the cord for the white connector in the house...I did tell him...lol. So I popped the new-used video card back in and hooked it up. No warnings that we don't have right video card any more.) Now, I'm stuck with this issue. Blah!
OK I really need help with this, The same this is happning and Iv tried what likeaboss recomends but ant working. any ideas would help heps or if you know what to do plsss let me know asap as am hanging out to play.
Still an issue for us, too. My hubby says he thinks he knows what to do to fix it...at least for us. If it works, I will try to get back in here and let you know what he did.
I tried deleting the update .MPQ, I've ended the process in Task Manager. Not sure what else to do short of reinstalling the game.

Join the Conversation

Return to Forum