Dye Helmets Removed For Monks? Or Bug?

Bug Report
Using this forum and copying text since I think this may be a bug since last patch.

Was this option removed?
I can no longer dye my headpiece.
If so Why?

quoted from different post in general

"If it's a legendary, then you are unable to dye it."

Nope.
Iv'e tried blues yellows, have not had a legendary drop yet.
Could it now be limited to just monk helmets not being able to dye now?
Bug?
I could dye/remove helmet before last patch, now I cannot.
Ill have to try a different class, and report back.

Just now tried a Wizard, and Witch Doctor. Dye's/Removers worked.
I'm taking this to the bug forum, or it is now not available for monks.

"Some helmets can't be dyed. Mostly some of the monk helmets."

That crossed my mind, however the same helmet I had dyed (actually removed) before patch was now visible apon reintering game, and no helmet for my monks so far has been able to be altered since patch.
Before Patch I had no problem to dye any monk helmet.

Join the Conversation

Return to Forum