FAILED to read a required file

Technical Support
I had this problem and use AV, after trying several of the proposed solutions this one worked.

http://us.battle.net/support/en/article/run-in-administrator-mode

Thanks for posting that.
Okay...so is Blizzard totally ignoring this issue? This issue is one it's fourth page and Blizzard is totally out to lunch on this? They haven't even responded since the second page.

I have this EXACT same issue with StarCraft 2. It worked fine until tonight when it ran a patch update, now the game refuses to run. I've completely disabled my antivirus (which is a crock, but I did it anyway), which was Microsoft Security Essentials. The game has run perfectly fine for months until the last patch, now it's not working.

Wake up, Blizzard. Fix this or I won't spend any more money on your games (and tell my friends the same thing).
i tried Removing my antivirus but nothing seems to help i still get this error can you help me please i cant install the game really annoying !! =(.....
i have this problem while installing the game...
it just gets to a point where the installation stops and writes this message..
i already deleted the antivirus program and disabled the firewall it still doesn't work..
what can i do? any suggestions...?
* Log in to your battle.net account
* Download the Diablo 3 Setup (Under Game & Codes>Download game clients)
* Let it load (it should not patch the whole D3 game client because it auto-detects your installation path)

Worked for me
did almost everything, still stuck with this annoying problem, please help.
Had this problem, changed my D3 folder properties from read only to normal
and that solved my problem, hope this helps


This solved this for me too, it seems if the launcher terminates for any reason it leaves some files read only, and it causes these problems when the security programs and/or settings won't allow the launcher to modify the flag later in order to access the file.
I cant even install the game. I just bought it yesterday. I contacted Tech Support, and they are running me through everything i tried. I got rid of my Kaspersky AV, There is no Agent.exe running until i start to install in which i even tried to kill that. Nothing. I wish i could play this game for once. Was so excited, and got shot down.

EDIT: Figures right as i post this, the repair tool works, and everything starts running smooth...ugh
I hate these type of errors, so you cannot have a damn antivirus if you want to play diablo 3, screw this...
I have this problem too. I am on Windows XP, I don't have any antivirus program. Today morning I played, now I can't. Blizzard, stop talking about our programs and computers, and look into your code. Something is wrong with D3, not with machines of about 70 ppl, who ask you for help.

Join the Conversation

Return to Forum