bought game. cant get pass skeleton king

Technical Support
i have just the same problem. Can someone fix the problem......
Yup. same problem here. Will try resetting my password a few times and see what happens.
Had the same problem. BUT, i did reset my password and it fixed it.
Same problem Blizz really sucks. Don't give a !@#$ about its customers it seems.
Couple of months later and the problem still exists!!
uninstall & download the game from the battle.net account. Hope it works :)
Did you use the key on the CD or the guest pass key on cardboard ?
alright now i passed the skeleton king but my nephew started his own account on my pc and plays all the way up to the skeleton king and realizes that he cant continue the game. so i give him a free pass card but that doesnt hlp either bcuz itswants him to install the game again. but the game has already been installed on my cpu. ofcourse he could take the game to his house and download and install it into his cpu but he doesnt wanna do that. so therefore what can he do to get the game to let him continue past the skeleton king. now my version of the game wasnt bought online but instead i got it out of the store. so if any1 can hlp me on this id appreciate it
For your Nephew to play further he is going to have to purchase his own copy of the game and upgrade his starter account. The key does not allow you to "install" the game (the software is actually free to download), it allows you access to the content through your battle.net account. Your account was upgraded with your key - hence you can get past the Skeleton King. HIS account has not had a key applied to it so he will not be able to until he does that.
ok thankyou
It's my hope "someone" at Blizzard reads these complaints. Apparently they're sending ticket reports into an unending wait loop. Stop ignoring your "paying" customers and fix the damn thing!
What complaints? And fix what? This thread was from JUNE with a few posts in September..... the ONE person who posted after that had a different issue and was given the proper guidance to resolve the issue. This is why it is not wise to necro threads.
hello every1 now i dont need any help passing the skelton king or anything even tho thats what every1 here is having problems with. i instead have a different problem and that problem is trying to log back into my europe regionm account. i for some reason keep getting this error code 14409 . now if some1 could tell me what i gotta do to get that to stop popping up so i can get back into the game i would b very happy
im sure some 1 can hlp me since im not that smart on figuring out some things but i do kn ow what im doing on a game
robbie,

Have you tried running the game as administrator? (right click the game icon, then left click 'run as administrator'.

That's just something to try for now as I don't think you'll get much if any thread response from tech support on the weekends.

If that doesn't work for you, you really should open a new thread and state your issues since this one is old and may get overlooked.

Join the Conversation

Return to Forum