[Fix] Failed to create D3D Device

Technical Support
Failed to create D3D Device:

This error is normally caused when your desktop resolution is set to a ratio/resolution that the game does not play nice with.

I do see this error commonly with in my work place for some of our clients, the easiest way to resolve this issue is to set you desktop resolution to the same resolution that you have D3 set to. You do not have to set your desktop to the same resolution as you play Diablo 3 in but you must pick a resolution that carries the same aspect ratio as the resolution you play the game in.

It appears to be an aspect ratio issue where you native desktop resolution is not quite 4:3, 16:9, or 16:10.

This seems to cause an issue with D3D creating the device. this is NOT a Diablo 3 issue, this can happen on many apps and is actually a common issue with abstract monitor resolution.

Lets do an example:

If you have your game set to be played on 1280x720 this is a 16:9 aspect ratio. but you have your monitor set to 1360 x 768, its very close to 16:9 aspect ratio, but it is in fact 6 pixels off. this situation will, and can throw the "Could not create D3D device" error.

Here is a wiki link to a table of graphical resolutions so you can pick one for your desktop and Diablo 3 of the SAME aspect ratio, that will make sure you do not see issues.

This didn't work for me. My issue is that I uninstalled Diablo III to try to change what drive it was installed to. It came up with this error after I tried to run it. So I uninstalled it from that drive and put it back on the drive were it was originally located. I still get this error. I have uninstalled and re installed in numerous times but it still has an issue with creating the D3D device
Edit d3prefs.txt and change "DisplayModeWindowMode" to "2".
Also, fix this Blizz.
Edit d3prefs.txt and change "DisplayModeWindowMode" to "2".
Also, fix this Blizz.

setting it to "0" Will place it in full screen mode, 2 will place it in windowed full screen, and 1 will place it in windowed.

options 1 and 2 will cause the D3D error if you have some sort of non standard monitor desktop resolution running like i sated in the first post.

Its derpy programming, Blackberry's sync software has this exact same issue when you run a weird desktop resolution.
This fix worked for me.

My scenario:

I have a y580 laptop, 660m nvidia (306.02 driver), and copied over d3 files (from "C:\Program Files (x86)\Diablo III\)...started up, worked fine.

Then, I plugged in a Plugable (brand name) DisplayLink USB 2.0 to DVI adapter and ran some movies through it to test my monitor. Worked fine.

Then tried to start diablo again, and got the 'creating d3d device' error. Tried reinstalling Diablo III from scratch, tried reinstalling drivers, tried deleting D3Prefs.txt file.

Fix: changed this line:
DisplayModeWindowMode "0"
DisplayModeWindowMode "1"

works fine now.
fixick's fix works great, however this remedy makes you run in windowed mode which is fine just has lower fps. Thank you fixick.
i just had this too and it had nothing to do with the resolution.

i had an HDMI cable that i just plugged in to a video converter, which i did not unplug once i finished using the converter.

after i unplugged it, Diablo started.

add this to the FAQ or something...
I had this issue today. Never had it before. It turned out to be DisplayLink software that I had just installed to use my USB dock. Once I removed it, the game started fine at full resolution of 1920 x 1080.
Solution: Right click on Diablo III icon > Properties > Advanced > Compatibility > Change Compatibility mode to Windows XP (Service Pack 3)
anyone can tell me in (normal language) how to do this?. I did delete my third party software did everything you guys did but i can put my mode of my screen on HDMI etc even did it on (right click, properties etc... to change resolution) Didnt worked i tried them all, any help?
This isn't caused by my screen resolution which is 1366x768. I do have a DisplayLink adapter for a third monitor, which I am guessing Blizzard doesn't play well with. Contrary to the OP, this is a problem specific to D3. Doesn't happen in any other game including WoW or Hearthstone and I never see this issue in any other application that I run.

Disabling the display on the DisplayLink adapter doesn't solve it, but unplugging it immediately fixes the issue.

And Compatibility mode doesn't work when you have the battle.net launcher, since the Diablo 3 launcher and base exe both just open it up.

I did manage to fix this by editing the d3prefs file located in the Diablo 3 folder in My Documents and changing the below lines to match my current resolution.

DisplayModeWinWidth "1280"
DisplayModeWinHeight "720"
DisplayModeUIOptWidth "1280"
DisplayModeUIOptHeight "720"
DisplayModeWidth "1280"
DisplayModeHeight "720"

I was nearly despaired, no "so-called" fix worked, until I found this thread.
To change the full-screen mode to a windowed mode worked fine, but regular full screen mode was impossible.
Final solution was in my case also to uninstall the DisplayLink software, as Eradour mentioned.
Thank you!
Uninstalling the DisplayLink software from my Win 7 computer solved the problem for me.
Just keeping this thread alive. I have run into this problem on two different computers now, and used two different solutions to resolve it, both of which are listed in this thread, so it's a game life saver!

The second time I ran into the problem (today), I'm sure it was caused by DisplayLink, but I didn't want to uninstall that as I have a docking station that uses it, etc., but the other solutions worked also.

Thanks all for the variety of solutions. Now I can go die in HC again ... :D
I've tried all of these and my computer crashes at character selection screen.

I've edited D3Prefs line to set V sync to 1, DisableTrilimanar set to 1, created a new D3 shortcut, added the line -usepageflip to the D3 Launcher under Settings then Game Settings, changed compatibility settings to Windows 7 and tried Windows XP Service Pack 3.

The game is not set to run off of integrated graphics in Nvidia control panel either. I can run all other games fine it's just something with D3.
galera e simples edite o ''d3prefs.txt'' e depois vai em "DisplayModeWindowMode" to "2".e pronto o meu aki resolveu.
I ran into this issue after the latest update from Windows (Update was applied last night). Apparently it updated my graphics driver (seemed more like it uninstalled them, as several programs kept alerting me that my drivers were out of date), so I had to reinstall the drivers for my GeForce card. Afterwards it loaded OK.
06/27/2012 04:45 PMPosted by GhostlyCrowd
hey guys, had this problem since i updated my windows to 8.1, i just downloaded the latest driver from nvidia (driver version 344.75) installed it then afterwards my games loaded ok.
Same problem and i did all the stuff u guys said above still not working! Need some help here since yesterday my window update I no longer able to load d3. gg blizzard!

Join the Conversation

Return to Forum