Error 3007 - Connection has timed out.

Technical Support
1 2 3 18 Next
This has happened to me twice in the last 5 minutes (lost 5 stacks of neph...)

Anyone else having connectivity issues?
It keeps happening to me as well, had 5 stacks, timed out without lag, came back in, timed out. Third try, got back to 5 stacks, booted again. Had a break, came back, got 5 stacks again, and about 10 minutes later, it just dropped me again.

Getting rather frustrating...
Just lost a 5-stack due to this, again. This is happening almost daily now.
I would reset my modem.
First time it's ever done this to me. Figure it's a server issue, always have to have a downtime before the downtime day for maint. :D
this is the first time it has happened to me also, i am farming hc on my monk and i timed out twice. lost 5 stacks both times, and luckily i didnt die, guess im done farming today
never had this problem before
Got back in, lost my stacks again. But now, it wont let me send any private messages, comes back with another error saying cannot send whisper message..
Just another reason why the 5 stack bonus is crap. Let me play for however long I want without farming 5 elite packs. normalize all the drops and forget this nephalem crap.
Has NOTHING to do with anyone's modem...this is server side because it's too widespread..

I've lost 5 stacks 3 times today...I'm done for the day....this is garbage.
Pretty bad there always seems to be an issue causing emergency restart or maintenance like the day before it's down for 4-5 hours for weekly maint. Definitely not an issue on my end, reset the modem/router, rebooted machine, still goin' down.

As I said, was giving me interesting errors about cannot send whisper messages, and an error with my request. Then a kick.

Probably not going to bother playing now, until tomorrow after the maint.
07/09/2012 12:26 PMPosted by Bacura
Just another reason why the 5 stack bonus is crap. Let me play for however long I want without farming 5 elite packs. normalize all the drops and forget this nephalem crap.


No, just don't take it away with a temp disconnect...and what about HC players experiencing this? I would want to punch something.
Twice in the past four hours. Both times in the thick of battle with a full team.
sigh I just got this too at 4 stacks...vey annoying. never happened to me before and internet connection is fine
07/09/2012 12:32 PMPosted by KnifestSharp
No, just don't take it away with a temp disconnect...


Exactly. I enjoy it the way it's set up, however I don't appreciate it with a server side disconnect. I'm not even lagging at all. Just a random slap.
Just happened to me a 2nd time as well. Just as i shot the killing shot at Kulle with 5 nv, the error popped up. I saw all the loot fall on the ground and I couldn't pick them up :(
Just got booted for the same thing.
I've been getting this the whole day...

Can't do my runs anymore.
Yep, happened to me a few times just now. Annoying since I'm finally on the verge of finishing Inferno.

Join the Conversation

Return to Forum