valid graphics card processor cannot be found

Mac Technical Support
"Diablo III cannot start because a valid graphics card processor cannot be found"

This is on the machine I have been playing on since release....help?
The same here !

WTF ? Since the release, it works properly, however since the last patch my video card is no more valid ???

I never encounter video problem during my play...so WTF ?
This message suddenly appeared my software are all up to date !!
Has anyone figured this out... I have a new 10.7 mac and I just recently got this message as well... Had just played earlier today? Thank you
????????
This indicates a driver issue. Can you post your system specs so we can recommend a course of action?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
I downloaded the 10.7.4 combo update and it fixed this problem. The battle.net support article suggested this as a fix and it worked...!
here are my specs any help would be great

NVIDIA GeForce 320M:

Chipset Model: NVIDIA GeForce 320M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x08a2
Revision ID: 0x00a2
ROM Revision: 3571
Displays:
Color LCD:
Resolution: 1366 x 768
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort
Display Connector:
Status: No Display Connected

NVIDIA GeForce 320M:

Chipset Model: NVIDIA GeForce 320M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x08a2
Revision ID: 0x00a2
ROM Revision: 3571
Displays:
Color LCD:
Resolution: 1366 x 768
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort
Display Connector:
Status: No Display Connected

Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Macintosh HD
Boot Mode: Safe

ecure Virtual Memory: Enabled
64-bit Kernel and Extensions: No
Time since boot: 15 minutes
Hey maxitaxi122,

Try what Chopshop tried and use this support article: http://us.battle.net/support/en/article/valid-graphics-processor-cannot-be-found-mac

The combo update should resolve the issue.
Hello, i have the same problem, but with nvidia geforce 9400m
i run the os 10.7.5
I don't mean to be a nuisance, but could you possibly post the link to the combo update?
Sure! We don't link them directly in the article, as it does change from time to time, it it does link to the Apple Downloads page.

For reference, the current combo updates are:

Join the Conversation

Return to Forum