Item failed to escrow

Bug Report
This is the error I got after putting an item up for sale and now the item is gone. Its on my completed list with the error Failed to escrow an item. the player is locked.
Yes they know, but what will they do... ROLLBACK?????
It can't be that difficult to return all items that failed to escrow to the players.
Just got this problem few minutes ago...what the hell Blizzard?
I got it too.
Failed to Escrow funds. The player is locked. (317402)
I got the same error as above. Kinda strange...Diablo had no problem taking REAL money from me 20 minutes earlier but now they won't let me spend fake money....confusing.
I lost a bow too. WTF Blizzard?
Same problem here, failed to escrow an item.
Same here, only... i bought tomes of secret on the gold AH.
got it here too\


edit: actually 1 on RMAH and 2 on GAH
I got it too, missing a ceremonial knife from GAH
I need my item back!
I also received this error. I attempted to post the auction during high server load, and noticed that it was pending in two different auctions, like it had duped. Now, coming back to it this morning, only the original item remains in my log, but it has "failed to escrow"
Same here, lost a ring last night trying to sell it. It just disappeared!
Same thing happened to me
No response from Blizzard at all?
Ok guys check your inventory...
I have the same problem, this is the second time.
First time (06.25.2012) i want to buy a item, than it say's Failed to escrow funds the given payment method does not have enough Balance tor escrowing funds(317410)
Second time (08.23.2012) I had a item for sale, than it say's Failed to escrow an item the player is locked(317402)
And i hear nothing from blizzard, watt can we do about this.
Items are gone, no gold nothing.
I got this as well, put in a 5m bid on an amulet, was outbid Tuesday night, so I'm sure with 1.0.4 being released that day server load was unreal, and it was very noticeable through performance....Anyway I decided an amulet with a 7m bin was overpriced a bit, so I bid 5m, a number I was comfortable paying for this specific amulet...The next day the auction is in my "auctions" tab, NOT completed on the bottom where it shows ur bids, it says "Not Winning" and item expired .. anyway same error, Failed to escrow funds...5m gold, poof any solution, resolution or most preferably re-imbursement for the time it takes for me to farm 5m....

Join the Conversation

Return to Forum