Cannot equip shoulder armor

Bug Report
My level 11 Hardcore mage "Linsha" has made two shoulder armors through the blacksmithing process. She is unable to equip them even though she is completely eligible to. I am in Normal in New Tristram, and I have not found any shoulder armor yet so I do not know if it is an issue with crafted items or with shoulders as a whole. I have exited and restarted the game, put armor in the stash and exited, neither seems to work.
same problem here....when i click on shoulders to equip, i notice potion icon on toolbar turns red
Having the same issue on my monk. First noticed it with a crafted Helm. But thought it was a fluke. Then again with the shoulders I just made. I can equip Helm or shoulder items that I have picked up just not crafted. IT has just been these two things so far. I crafted something for my feet and it worked fine.
I am also having the same issue with shoulder armor I crafted on my Wizard. I crafted some other items and was able to equip them just fine.
I have a stash full of hand-me-downs and I tried equipping shoulder armor while in a solo game. I tried right clicking it from my inventory, dragging it from inventory and stash, selling and buying back to a vendor, as well as dropping on ground and picking it up again. None of these methods equipped my shoulders. I tried crafting new shoulders and those also refuse to equip. (However I got a better pair for when this is fixed :)
I has the same problem, but I was able to equip the piece of equipment on my next level. Happened with a lvl 9 shield on my Hardcore Monk. I managed to equip it at lvl 10. And then it happened again with the lvl 11 shoulders, but I was able to equip them at lvl 12.
Same problem. Level 11 monk!
I just crafted some bracers for my wizard and got the same problem.
Lvl 9 Barbarian, solo, with crafted shield.
Sorry,and also the crafted lvl9 breeches.Thank you.
Same issue with crafted Wizard wand (lvl 6)
Same here. Crafted 6 lvl 9 shields and i could equip some of them but not the one i wanted to equip. Could finally equip it at lvl 10.
Here too lvl 9 wizard. Problem started with new patch :(
Level 11 female WD HC. Crafted a pair of shoulders and they will not equip.

*Able to equipd level 11 shoulders at level 12*
Same problem with level 9 leggings *crafted* and level 11 shoulders *crafted on my Softcore Witchdoc!
Same here level 9 leggings *crafted* on monk hc....
yep same problem lvl 11 Wizard
Same thing happens to my lvl 12 Wizard;crafted a shoulder piece,but unequipable..... Btw did any of the bug issued got fixed?
same here, able to equip the lvl 11 shoulder within lvl 12

Join the Conversation

Return to Forum