[BUG] "Bashanishu" achievement not awarded

Bug Report
Prev 1 5 6 7
I could not complete the Bashiok achievement either, despite doing everything that was asked.
This was literally my 51st run to find him so I am not particularly happy about it.

1) I had 3 different blades, all post patch 1.05. None worked.
2) I removed the skill to the "normal" attack with only the Rakanishu's Blade equipped, dropping my 5 neph stacks.

I took a screenshot of this fully demonstrating all of the above. It's weird because there are a few other achievements that I just can't do, like get the bloodstained letter or a spirit stone from the vendor....
wonder if they plan on fixing this anytime now
same - twice!
Same here. Found him for the fourth time in all my games now, Tried to hit him this time even with a today found new Rakanishu's Blade. And of course not awarded. WTF blizz? This isn't a new bug, people are getting this since a few patches ago. should be fixed till now.
As i got this now on a new created char, with a new found blade on norma. man, that isn't funny.
LET US HIT BASHIOK! ...please
I just tried for this achievement not realizing it is a known bug. I was wondering if this will be fixed in the next patch, since there is no mention of it in the P.T.R. notes.
Gah! have been farming this avhivement for weeks and have the same problem.

Blizzard would be dammed if they dont fix this and give me the Achivement when i have used this many hours on it!
Is it fixed now ?
Nope, not fixed yet... I finally met the guy after farming for keys for a week. I'm glad I wasn't just grinding for this achievement,
Que outras conquistas estão com BUG e quando será possível completalas?
Tenho 95% concluído neste momento...
Anyone willing to help me complete this achievement?
I have completed 95% of the achievements ...
Already burned the 3 monsters at the same time but did not work.
Paid 100,000 Gold!
add me in the list

i've been keeping this crappy rakanishu's blade since august in my inventory (should be before 1.04 patch), today i finally found that damn monster, removed the skill (as i did with the quest "punch diablo") and it's still not working

i'd like to know the reason for which this bug is still not fixed, but i fear i alrady know the answer
I have him in front of me right now, just had the achievement too. On Europe servers for those who are interested.

I'll keep the game opened for an hour (Patriarch#2287).

I dropped my blade shortly after the game was officially released, and kept it in my stash for the achievement (to do later :p)

PS: today, made about 50 runs to get him (5min / full map), so frustrated just after seeing an ally killing him in a standard game :p couldn't believe it ^^ that gives a total of about 200 runs counting previous fail sessions.
this is still not fixed, i had 2 blades equipped ,i hit him with normal attacks (not skills) , still nothing...

can anyone help plz??
Funny part is that the Demon Hunter class cannot even attempt at obtaining this achievement on console. Why? Because they've removed the ability to use 1H weapons with that class. Nobody ever gave a reason for this.

ps: for the 1000th time, I AM NOT LOOKING FOR A MELEE BUILD.
I also damaged bashiok with the rakanishu blade with a regular melee attack and didn't get the achievement; I even killed him with the blade equipped. Is this still bugged? It seems to be.

Join the Conversation

Return to Forum