authenticator removed but still being asked

Technical Support
1 2 3 7 Next
i removed my authenticatorbut when logging into to game it still asks for it any help would be much aprreciated thanks.
xXSoonXx,

I've issued a reset to the account which ought to clear this up for you. If not, try connecting to your Battle.net Account Management page and changing the account's password. That will also refresh the account data.
same problem here..
i removed my mobile authenticator from my account but still being asked.
i changed my password but when i log in with the new password, it was wrong.. i entered my old password(prior to the new one) and it goes in and authenticator is required..

please help me too..
i discovered that in americas region i cant log in my new password. however in asia, i can log in with it..
arghh.. please help me..
Mjolnir23,

The account has been reset. Can you see if it's working properly now?
thank you so much!! i can log in now.. :)
same problem here..
i removed my mobile authenticator from my account but still being asked.
i changed my password but when i log in with the new password, it was wrong.. i entered my old password(prior to the new one) and it goes in and authenticator is required..

please help me too..


same issue here Blizzard, please help.
Ive also tried resetting my password http://us.battle.net/d3/en/forum/topic/6566036559, but it's still doing the same thing thats been posted above.
Xeno,

The account has been reset. Can you see if it's working properly now?
Hi Omrakos,
The same thing is happening to me. I've had my authenticator removed, changed my password and only my old password works which asks for the authenticator
Omrakos, I have the same problem with my WoW account. Can you possibly help?
did reset delete something at acount ? if not i need one to, same problem that ppl have here, authenticator removed but it keep askin for code when login

btw i can log only asian server, any idea why ? on us and eu i get 3003 error, iam from israel playing on eu client(tryed them all same problem)
Can you please help me? its been 3 days now since i have access to my account i already removed the authenticator but it still ask me when i log in. And I already reset my password and stilll same. Please help me i just want to play my account.
Difki and PHERX23,

The accounts have been reset so give them another try please.
Thank you sir
same problem here... removed the authenticator but still being asked on the game as i log in. need help please.

thanks!
Notty View profile

Edited by Notty#6765 on 10/18/12 11:13 PM (PDT)
same problem here... removed the authenticator but still being asked on the game as i log in. need help please.

thanks!


any update??? still cant log-in
i already reset my account password... it now says that my login information was incorrect (error 3). But i can login in my battle.net account. kindly resolve this issue ASAP....

thanks in advance!
same here.
i removed authenticator from my account but still being asked.
i changed my password but when i log in with the new password, it was wrong and old password works but authenticator is still required.
I have the same problem as cougar. Removed authenticator and changed password. However, at diablo3 login page, i still have to use the old password and authenticator code still needed. Please help. Thanks.

Join the Conversation

Return to Forum