Diablo 3 doesn't work in Windows 8

Technical Support
Hey there,

I have just upgraded to the final build of Windows 8 via Microsoft's website - upgrade from Windows 7, to Windows 8 Pro.

After clicking Play on the launcher the game crashes, with an option to send a crash report to Blizzard.
I have tried fiddling with compatibility settings, but nothing works.
The game has been installed "Fresh" after upgrading to Win8.

Any tips ?
I'm having the same issue. I've tried everything from deleting the battle.net folder. giving it permissions, administrative start. Compatibility settings. re-installing diablo. Updating and downgrading my nvidia drivers. everything! nothing works!

If I change compatibility settings I can either get an error report, or have it where it passes the launcher but the agent just runs in the background, but nothing happens (in task manager).

My error:

Blizzard Launcher.exe: (build 1881)

Exe: C:\ProgramData\Battle.net\Client\Blizzard Launcher.1881\Blizzard Launcher.exe
Time: Oct 27, 2012 1:00:58.514 PM
User: XXX
Computer: XXXXXXX

This application has encountered a critical error:

ERROR #1 (0x13370001) Fatal Exception
Program: C:\ProgramData\Battle.net\Client\Blizzard Launcher.1881\Blizzard Launcher.exe
I doubt Blizzard with do anything to fix this for quite some time. I think the best is to just revert back to 7 if you want to play.....

I found this we could follow to go back. I play this game daily so I can't wait for a fix --> http://support.microsoft.com/kb/971760
I have managed to resolve it.
Initially I chose to upgrade from Win7 by keeping all my files, settings, etc.
When Diablo didn't work I simply uninstalled it, deleted the temporary stuff it left behind, and reinstalled it, with no luck.

Since I didn't have much to reinstall, I decided to test the new "factory reset" feature of Windows, which has wiped my C: drive, and reinstalled everything from scratch.

Long story short: it works !

So, if you guys still have issues with Diablo under Windows 8 and are willing to wipe everything, this solution works.
Figured out the issue. Im using MSI Afterrburner. Once I closed it, it worked!
Wow, you helped out a ton. I was having a bunch of problems with sc2/d3 and many steam games. Saw your post and closed EVGA Precision and everything works now.
Glad I could help man... I wish i figured it out sooner before wiping out my entire c drive partition.

At least its working now... Im sad to see MSI go, but im sure there will be an update, in the meantime im using nvidia's fan controller for now
I had the same crash issue but I closed EVGA precision and it works fine I just have to turn it back on after launch or else my graphics car will fry lol
Winblows 8? Can I get a HELL NO?
I'm trying to install Diablo 3 on my new computer. I've got Windows 8 on it, and the installation takes ages! it's up to 0,2% after 30 minuts!!

What can i do to make this game work? I'm clueless!
10/27/2012 06:02 PMPosted by greymatter
Figured out the issue. Im using MSI Afterrburner. Once I closed it, it worked!

Gracias MAESTRO, me venia quemando el coco para tratar de solucionarlo, es el MSI AFTERBURNER el problema con windows 8, nuevamente gracias

PD TAMBIÉN soluciona el mismo problema con el cliente de STARCRAFT2, posteen en el foro asi la gente ya sabe
Diablo 3 is not stable on Win 8 for me. Fresh D3 install on fresh install of Win 8 on a new computer. Screen freezes, system reboots, video scheduler internal error and d3d errors. Doesnt matter if i run it from Desktop or Start screen. Crashes between 5 & 30 minutes but high graphics activity seems to trigger a massive drop in fps followed by error message or forced reboot. All other games work fine, including the Steam games.

Drivers are all updated. Monitor resolution matches game resolution (1920x1080). Reset D3 preferences from launch screen. Decreased video settings. I've tried everything i could search for. i7 3770k, 16Ram, 240GB SSD boot drive, 1TB Data (D3 drive), gtx650TI
have win 8 and just installing but... im computer noob so... what the hell is EVGA Precision and MSI Afterburner?
for anyone withan alienware laptop, try switching graphics cards, function f7 and it will reboot with different settings, allowing d3 to run.
when i tried installing the game, it keeps telling me i don't have the minimum specs for the game....and well i am not a computer person. but i really want to play!! someone help me please!!!!!
10/27/2012 06:02 PMPosted by greymatter
Figured out the issue. Im using MSI Afterrburner. Once I closed it, it worked!

Thanks for this, you rock. :x
10/27/2012 06:02 PMPosted by greymatter
Figured out the issue. Im using MSI Afterrburner. Once I closed it, it worked!

Thx a lot, same problem here, closing MSI Afterburner worked for me.
What is error 14404 when authenticating?
i have the same problem I have the error 14404 n my com is window 8 ? anyone know how to solve this problem?
Yeah i'm getting the same 14404 error, cant find a fix a fix anywhere..
is this just a windows 8 issue?? as its only affecting my laptop with windows 8, for all accounts that try to log in

Join the Conversation

Return to Forum