Error 3003 from RMAH (6th day now)

Technical Support
Prev 1 2 3 9 Next
A number of us seem to experience this, so this is not an isolated problem.

I had tried all the things suggested above, and it did not work for me.
Bump,

I opened a ticket and got a response that seemingly ignored what I'd said.

Have tried everything in the list of stuff previously posted in this thread also.
I have similar problem and raise the ticket with different answer from those found here as copied below:

The error 3003 will usually happen if the connection was interrupted while in the AH, anything like a disconnection could cause it.

I'm not really sure how it has something to do with my end since i never encountered problem before and also in game connection is smooth so i guess something in the patch that caused this. I hope they really notice that a lot of ticket has been raised for similar issue.
Same problem here, error 3003 failed to escrow funds blah blah, worked fine pre 1.05 has not worked since.
In the same boat with everyone else, please fix this ASAP blizz

Australian here also.
actually we can't bid or post anything on RMAH with paypal(b.net balance is fine),i personal think only SEA(including New Zealand and AUS)facing this issue!blue help!
Hi, i'm facing this issue as well.. hope Blizz fix this soon. Can't sell a thing, 2nd day for me
having the same issue. submitted a ticket and got a reply asking me to check the host file. doesnt solve my problem as i'm on OS X
Still cannot do it, 3rd day now...
OK guys, I already bugged them up thru phone and web support and same with you guys I have experience the same issue and all type of possible course of action (troubleshoot) to arrest this matter... as in the end I directly inform them that the problem is not ours (players).

As a respond from their end is:

" My apologies about the wait - we're currently experiencing a high volume of contacts and are working through all issues as efficiently as possible, but we also want to give each player the attention you deserve.

There was a recent issue with the D3 Auction House that we are resolving, but I don't have an ETA on it at the moment.

Transactions on the Real Money Auction House can take up to 48 hours to report on items and 5 days to return proceeds on auctions under normal circumstances.

Have a great day! "

ERGO... they dont know yet how to deal with it... GREAT!!! I am beginning to be pissed off, but let them give a chance since they are trying to make our game play enjoyable as possible. Hoping that this would be acted soon...
This was what i got

My name is Saunhis with Account and Technical Services, and I was able to read about the RMAH error you encountered. I will submit this feedback on up to the appropriate parties for you. The error message you received is a known issue that our Development Team is working to resolve.

In the meantime, we can try some troubleshooting steps to see if we can get you back up and running. To prevent sendind a wall of text, please try the below steps listed on our support pages, to see if this helps at all:

Power Cycle
https://us.battle.net/support/en/article/resetting-network-devices-and-flushing-the-dns-cache

IP Release, Renew, and Flush DNS
https://us.battle.net/support/en/article/ip-release-renew-and-flush-dns

Close Background Applications
https://us.battle.net/support/en/article/shutting-down-background-applications

Optimize Internet Connection
https://us.battle.net/support/en/article/optimizing-your-wireless-or-lowspeed-internet-connection-pc

Update NIC Drivers
https://us.battle.net/support/en/article/network-card-support

In some instances, the specific error you encountered can sometimes be caused due to a modified host file. This is usually very rare and does not generally occur for most internet users. For the steps on check the windows host file, please visit our support page: https://us.battle.net/support/en/article/checking-your-windows-hosts-file.

If you have any further questions or need more assistance, you are welcome to reply to this ticket. Please keep in mind that the response may come from another representative.

I guess are finally admitting there is a problem
finding it hard to believe that after all this time it has not been fixed WOW
4 days, no RMAH :'(
Yeah.
same for me too.
I can't sell anything in RMAH at the moment due to the very same reason.
From Malaysia btw.
Same issue here. Australian and it worked fine before 1.0.5a.
same problem here

"due to heavy traffic we cannot process your transaction"

its been 4 days now

Its more fun in the Phillipines
Same problem here. Working fine pre-patch. Sigh.
they just don't want to solve this?
just got this reply from them..."Greetings,I'm sorry to hear you have run into an unexpected issue and I appreciate you taking the time to inform us of the issue. However at this time we're asking all players to report all bugs via the Diablo III Bug Report forums located here:http://us.battle.net/d3/en/forum/5386229/Please be sure to use the search feature to locate any threads regarding the bug you are reporting as it helps the Development track what issue have the largest impact on the game as well as keep all reports regarding the issue more organized.For more information on how to report a bug in Diablo III, please see our Reporting Diablo III Bugs support article (http://us.battle.net/support/en/article/reporting-diablo-iii-bugs).Thanks for your time and if you have any further questions, please let us know.Regards,"
none of the things they have suggested so far work for me. the error 3003 failed to escrow funds is a massive issue affecting many people it seems. hopefully no more waiting its been 4 days now. They have to do something soon! patch 105 was ok but 105a was a disaster in my view.

Join the Conversation

Return to Forum