Patch 1.0.5a causes sound lag/stuttering

Mac Technical Support
I'm on a rMBP and updated to 1.05a. The patching went fine, started up D3 and noticed I had around 12fps, so I shutdown my computer and reset the SMC and my fps was up to normal again. It is a known bug, but that has never happened to me before.

Now my problem is that I get some stuttering where it cuts off the sound (like when my follower (scoundrel) says something) and the game freezes for about 1/2 second (and my follower's sentence never completes). This happens very often. I tried changing to lower sound settings and also lower Graphics, but nothing helps.

Feels almost like there is some sound effect that can't play or something and therefore it instead shuts down the audio and the whole game freezes for about 1/2 second. Then all is working as normal, this happens about 3 times per minute or so and it happens most when I kill a lot of monsters.

I've tried the usual tips, such as deleting cache folder, deleting agent.db, repaired permissions and reset SMC. Nothing helped.

My spec:

Intel Core i7 2,6Ghz
Nvidia 650M 1024MB
512GB SSD (314GB available)
OS X 10.8.2

Edit: changed the title to be more accurate.
that kind of issue sounds like a possible overheat or maybe the cpu bug that was fixed by firmware update. do you have the latest firmware?

you may find out more about cause by opening "" from applications/utilities then clicking "all messages" about the time the stuttering happens to see what it's reporting as the cause in the log output.
You forgot to link to your thread listing the firmware updates for the new Macs Omegal! :P

Specifically, the OP will want this firmware update:

Firmware Updates

MacBook Pro Retina EFI Update 1.0

This update resolves an issue which can cause the system to hang during heavy processor loads, and resolves an issue where NetBoot does not function properly when using an Ethernet adapter.

Original thread and quoted material courtesy of Omegal/MysticalOS.

Edit: Why don't you just repost your OS/Firmware updates thread on this side too Omegal. It'll help a lot since these forums are less frequented by helpers/support than the WoW forums seem to be, and any available info would serve the players very well. :)

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
run hardware test and a verify disk on the hard drive. This sounds like I/O lockups and blocking, not an overheating problem.
Thanks for the replies, so far. :)

My logs and system information is in the end of my post.

I've done the following:

* Tested the SSD disk and also repaired permissions and checked the file system. No errors at all.

* Booted into safe mode and rebooted into normal mode again to get rid of the "mdworker[349]: Unable to talk to lsboxd" message.

* Left the computer off during the day (so it was cold to the touch) and booted it up and immediately started D3 and the lag was there from start. Quit D3 and checked temperatures, no temperature was over 65°C so it was pretty cool.

* Played "Trine 2" for a long time so fans got spinning more than they do with D3, no problems at all.

* Checked activity monitor, and I don't have anything that hogs the CPU in the background.

Is anyone else running D3 on a Macbook Pro 15" Retina without these problems since 1.0.5.a?

I can't find anything wrong with the computer at all except those messages in the log below.

I think the stuttering sound is enhancing the "lag feeling", the actual lag maybe is about 1/5 second but when the sound stuttering appears it sort of restarts all sound. So even the background music is cutoff and starts from the beginning.

It even happened a couple of times without any mobs/monsters on screen, just me walking.

At first I thought there was a sound effect from a specific drop (like when a gem drops) but I can't find anything it has in common. Tried it with music disabled but it's still there just less noticeable because then I can't hear the music restart.

My computer is fairly clean and standard installation and the annoying problem came immediately after the patch.

System information:


System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Time since boot: 2:20


Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2,6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32


Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort


Input Source ID:
Keyboard Layout: ISO

OS X Log files since starting Diablo and quitting

There were several stutters and I know that one stutter happened 20:02 and one 20:04.

2012-10-29 20:01:49,086 Diablo III Launcher[356]: Current process is NOT running as Admin: -60007
2012-10-29 20:01:49,000 kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=365[Blizzard Launche] clearing CS_VALID
2012-10-29 20:02:01,449 WindowServer[94]: CGXMuxCapture: Starting
2012-10-29 20:02:01,450 WindowServer[94]: CGXMuxCapture: Acquired
2012-10-29 20:02:01,450 WindowServer[94]: Display 0x42803c0 captured by conn 0x12fbb
2012-10-29 20:02:01,500 Diablo III[370]: *** WARNING: Method convertPointFromBase: in class NSView is deprecated on 10.7 and later. It should not be used in new applications.
2012-10-29 20:02:02,623 Diablo III[370]: *** WARNING: Method convertRectToBase: in class NSView is deprecated on 10.7 and later. It should not be used in new applications.
2012-10-29 20:06:55,582 WindowServer[94]: CGXMuxCapture: Released
2012-10-29 20:06:55,583 WindowServer[94]: Display 0x42803c0 released by conn 0x12fbb
2012-10-29 20:06:55,587 WindowServer[94]: MPAccessSurfaceForDisplayDevice: Set up page flip mode on display 0x042803c0 device: 0x1064b5320 isBackBuffered: 1 numComp: 3 numDisp: 3
2012-10-29 20:07:09,894 coreservicesd[27]: SendFlattenedData, got error #268435459 (ipc/send) invalid destination port from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=249
2012-10-29 20:07:34,704[392]: Bug: 12C60: liblaunch.dylib + 23849 [2F71CAF8-6524-329E-AC56-C506658B4C0C]: 0x25
2012-10-29 20:07:34,749[392]: CGSGetWindowTags: Invalid window 0xb4
2012-10-29 20:07:34,749[392]: kCGErrorFailure: CGSSetHideOnDeact: error getting window tags
2012-10-29 20:07:34,897[392]: *** WARNING: Method userSpaceScaleFactor in class NSWindow is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
Started D3 and logged in and it happened in the Character screen a couple of times. Only thing in the log was:

2012-10-29 21:05:59,068 Diablo III Launcher[516]: Current process is NOT running as Admin: -60007
2012-10-29 21:05:59,000 kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=525[Blizzard Launche] clearing CS_VALID

No spike in activity log or anything...

Gonna try a reinstall of Diablo I guess, feels like something went wrong/got corrupted when I installed the patch. :(

Have you installed the EFI firmware update as Omegal suggested? I linked it in my first post after his. You will need to reset the SMC after doing so. This article has info on resetting your SMC:

You may also wish to disable Spotlight for the volume that Diablo 3 resides on. To do this, go to System Preferences -> Spotlight -> Privacy and drag the drive containing Diablo 3 into the Privacy window. This will stop indexing on that drive. Indexing is one of the major causes of Diablo 3 stutter outside of its own asset loading mechanisms.

The "" entries have to do with Powerbox, which in Lion and Mountain Lion is responsible for file I/O tasks such as bringing up save/open dialogue boxes. The fact you're getting errors with the window server in conjunction with this means one or more windows that are open (or have been opened and subsequently killed, such as the big Diablo Skull on launch) are causing Powerbox to basically continually attempt to bring up the dialogue box, but since there is no dialogue box used with Diablo 3, it's failing.

The next time you want to launch Diablo 3, first open Activity Monitor and then launch Diablo 3. Once logged in and at the character select screen, hit CMD-TAB and check Activity Monitor for a Powerbox entry. If it is taking up excessive CPU, you can safely force quit it and it will re-launch itself the next time it is needed (it's a daemon).

You can also try launching Diablo 3 by doing the following:

1) Open Terminal.

2) Type the following line into the Terminal and hit Enter:

open /FolderDiablo3IsInstalledIn/"Diablo III"/"Diablo" --args -launch

In most cases the /FolderDiablo3IsInstalledIn will be /Applications, so your Terminal line will look like:

open /Applications/"Diablo III"/"Diablo" --args -launch

This launches Diablo 3 by bypassing the Launcher completely. It is not normally recommended procedure to do this, but in this case, doing so may help determine if the Launcher is causing Powerbox to go nuts, or if Diablo 3 itself is. If you get no lag when launching Diablo 3 by itself via the Terminal, than the Launcher is having issues and the following items should be deleted before re-launching the Launcher:

Folder: /Users/Shared/Blizzard
Folder: /Users/Shared/
File: /Diablo III/Diablo III.mfil

This will eliminate any errant caches, as well as force the Launcher to rebuild the Agent program used in Blizzard's games. With any luck, one (or all) of the steps above will solve your issue.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Sorry, forgot to mention that the EFI update has been installed since Apple released it. So my Mac has all the latest updates and the SMC is reset.

I have now deleted ALL Blizzard files ( on my computer and reinstalled Diablo3 from scratch. But still same thing.

Checked the activity monitor several times, but can't find any problems. No spotlight indexing either. I can see a (very short) disk write spike when the stuttering appears.

Started D3 without launcher as you described above, but still same thing.

It happens in the Character screen too, so it's not some performance issue.

I'm fairly certain that patch 1.0.5a is causing this since I haven't made any changes on my computer between 1.0.5 and 1.0.5a. I'm giving up, since the next thing to try is reinstall OS X from scratch, and that will probably not help. So I'll quit playing until more Retina owners get the same problem, and i gets fixed.

Thanks for your help/efforts. :)
As a final test, could you create a new user account with administrator privileges, and try this from there? I've seen several recent issues with account specific problems on the rMBPs where using a new account allowed proper gameplay in Diablo 3, but the original account was somehow mucked up.

I wouldn't give up so easily on this - expecting others to suddenly develop the same problem and hoping it gets fixed by proxy of widespread occurence isn't usually a good way to go about things. :)

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
I've googled and found that there are other people having the same problems (not only with rMBP). A colleague at work who has a MBP 2011 has the same issues since patch.

Thanks so far, I'll try your suggestion and report back to this thread (my current account does already have admin rights).
Hi again,

I have now tested to create a new user account with administrative privileges and that account experiences the same problems. After that I gave my normal user (which have admin rights) read/write permissions to the Diablo3 folder and its subdirectories, but the sound still stutters/restarts.

Guess I haven't given up quite yet. ;)

Below is a part of my D3Debug.txt at the moment when the sound stutters/restarts, and it seems almost like D3 is doing something that resets the sound. If I look in the file after a longer gaming session these messages appear several times.

The stuttering appeared exactly at 21:56:53

2012.10.30 21:56:27.898936339 Initializing client world A3_Battlefields_02...
2012.10.30 21:56:27.899167090 Initializing client world a3dun_hub_keep...
2012.10.30 21:56:53.081854159 Disposing sound subsystem...
2012.10.30 21:56:53.081985957 Start SoundPlatform::Dispose()
2012.10.30 21:56:53.083575467 StopOVTStream
2012.10.30 21:56:53.087990931 - Releasing DSP effects
2012.10.30 21:56:53.089055564 - Releasing FMOD System
2012.10.30 21:56:53.151258933 Finish SoundPlatform::Dispose()
2012.10.30 21:56:53.151318735 Initializing sound subsystem...
2012.10.30 21:56:53.153850026 ****** Sound Device Caps ******
2012.10.30 21:56:53.155469992 Found 1 sound drivers:
2012.10.30 21:56:53.155701111 Driver 0: 'Built-in Output'
2012.10.30 21:56:53.155741485 Min Freq: 44100, Max Freq: 44100
2012.10.30 21:56:53.155892776 Speaker Mode: Stereo
2012.10.30 21:56:53.155942809 Driver Capabilities:
2012.10.30 21:56:53.156071395 Device can do multichannel output, ie greater than 2 channels.
2012.10.30 21:56:53.156200691 Device can output to 8bit integer PCM.
2012.10.30 21:56:53.156250826 Device can output to 16bit integer PCM.
2012.10.30 21:56:53.156375008 Device can output to 24bit integer PCM.
2012.10.30 21:56:53.156499464 Device can output to 32bit integer PCM.
2012.10.30 21:56:53.156574859 Device can output to 32bit floating point PCM.
2012.10.30 21:56:53.156631508 Selecting driver 0 (Built-in Output)
2012.10.30 21:56:53.156765566 Speaker Mode: Stereo
2012.10.30 21:56:53.156826118 Initializing sound with 32 channels
2012.10.30 21:56:53.218409850 ****** SoundPlatformFModGlobals ******
2012.10.30 21:56:53.218506548 bResetDevice: 0
2012.10.30 21:56:53.219023828 nNumDrivers: 1
2012.10.30 21:56:53.219101574 nDriverToUse: 0
2012.10.30 21:56:53.219243880 ptFModSystem: 0x1e0001d8
2012.10.30 21:56:53.219310232 pFModMemory: 0x1e000000
2012.10.30 21:56:53.219469981 nFModMemoryAmount: 100663296
2012.10.30 21:56:53.219541433 nNumChannels: 128
2012.10.30 21:56:53.219676209 ptCachedSoundAllocator, used block count: 0
2012.10.30 21:56:53.219753523 ptCachedSoundAllocator, free block count: 640
2012.10.30 21:56:53.219888301 ptCachedSoundSampleMap, count: 0
2012.10.30 21:56:53.220013456 ptCachedSoundStreamMap, count: 0
2012.10.30 21:56:53.220137223 ptLRUSoundSampleList, count: 0
2012.10.30 21:56:53.220258208 ptLRUSoundStreamList, count: 0
2012.10.30 21:56:53.220320663 arPlayingSounds: 0x4c81c600
2012.10.30 21:56:53.220442955 nCacheSampleSize: 0
2012.10.30 21:56:53.220575755 nCacheStreamSize: 0
2012.10.30 21:56:53.220942204 nFModCurrentAlloced: 48436080
2012.10.30 21:56:53.220972860 nFModMaxAlloced: 48436080
2012.10.30 21:56:54.191604959 Disposing sound subsystem...
2012.10.30 21:56:54.191742749 Start SoundPlatform::Dispose()
2012.10.30 21:56:54.193242900 StopOVTStream
2012.10.30 21:56:54.200645075 - Releasing DSP effects
2012.10.30 21:56:54.201724984 - Releasing FMOD System
2012.10.30 21:56:54.252367747 Finish SoundPlatform::Dispose()
2012.10.30 21:56:54.252462076 Initializing sound subsystem...
2012.10.30 21:56:54.255012113 ****** Sound Device Caps ******
2012.10.30 21:56:54.256971591 Found 2 sound drivers:
2012.10.30 21:56:54.257199506 Driver 0: 'Built-in Output'
2012.10.30 21:56:54.257246838 Min Freq: 44100, Max Freq: 44100
2012.10.30 21:56:54.257330141 Speaker Mode: Stereo
2012.10.30 21:56:54.257382767 Driver Capabilities:
2012.10.30 21:56:54.257517067 Device can do multichannel output, ie greater than 2 channels.
2012.10.30 21:56:54.257570154 Device can output to 8bit integer PCM.
2012.10.30 21:56:54.257731529 Device can output to 16bit integer PCM.
2012.10.30 21:56:54.257959950 Device can output to 24bit integer PCM.
2012.10.30 21:56:54.258032962 Device can output to 32bit integer PCM.
2012.10.30 21:56:54.258167296 Device can output to 32bit floating point PCM.
2012.10.30 21:56:54.258441879 Driver 1: 'AirPlay'
2012.10.30 21:56:54.258475408 Min Freq: 44100, Max Freq: 44100
2012.10.30 21:56:54.258606511 Speaker Mode: Stereo
2012.10.30 21:56:54.258732623 Driver Capabilities:
2012.10.30 21:56:54.258869670 Device can do multichannel output, ie greater than 2 channels.
2012.10.30 21:56:54.258990540 Device can output to 8bit integer PCM.
2012.10.30 21:56:54.259113578 Device can output to 16bit integer PCM.
2012.10.30 21:56:54.259236580 Device can output to 24bit integer PCM.
2012.10.30 21:56:54.259286284 Device can output to 32bit integer PCM.
2012.10.30 21:56:54.259410604 Device can output to 32bit floating point PCM.
2012.10.30 21:56:54.259534199 Selecting driver 0 (Built-in Output)
2012.10.30 21:56:54.259664008 Speaker Mode: Stereo
2012.10.30 21:56:54.259722304 Initializing sound with 32 channels
2012.10.30 21:56:54.322126771 ****** SoundPlatformFModGlobals ******
2012.10.30 21:56:54.322223285 bResetDevice: 0
2012.10.30 21:56:54.322631940 nNumDrivers: 2
2012.10.30 21:56:54.322688159 nDriverToUse: 0
2012.10.30 21:56:54.322867412 ptFModSystem: 0x1e0001d8
2012.10.30 21:56:54.322923535 pFModMemory: 0x1e000000
2012.10.30 21:56:54.323060337 nFModMemoryAmount: 100663296
2012.10.30 21:56:54.323210106 nNumChannels: 128
2012.10.30 21:56:54.323334293 ptCachedSoundAllocator, used block count: 0
2012.10.30 21:56:54.323459300 ptCachedSoundAllocator, free block count: 640
2012.10.30 21:56:54.323508553 ptCachedSoundSampleMap, count: 0
2012.10.30 21:56:54.323636220 ptCachedSoundStreamMap, count: 0
2012.10.30 21:56:54.323685050 ptLRUSoundSampleList, count: 0
2012.10.30 21:56:54.323808832 ptLRUSoundStreamList, count: 0
2012.10.30 21:56:54.323933808 arPlayingSounds: 0x5f343600
2012.10.30 21:56:54.324060455 nCacheSampleSize: 0
2012.10.30 21:56:54.324116150 nCacheStreamSize: 0
2012.10.30 21:56:54.324649034 nFModCurrentAlloced: 48436096
2012.10.30 21:56:54.324685566 nFModMaxAlloced: 48436096

If a Blue could read this maybe they could fix it. :)
It looks like a lot has been done here. I'll send this up for review and see what the team thinks.
/noms 'splodey sheep and returns to his free Doritos Locos Taco(s).

Mmm...multiple taco bells near each other = lots of free tacos...

Here's hoping the team can find something in his debug log. I'm running out of suggestions off the top of my head.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
One follow-up question, does this happen for all audio that is currently playing or just the game audio?
Dirkgently, good idea. I will listen to some music in iTunes while playing and see (hear) if I notice any stuttering.

Machkhan: Let me know if there is something else you want me to try (except reinstalling OSX).

Thanks so far for your tips/ideas. :)

Ps. I've tried some more SMC and PRAM resets, but it didn't help.
Hi again,

Now I have tried listening to some music in iTunes while playing D3 and iTunes was unaffected.

Since it was difficult to hear all sounds at the same time, I turned down the volume in D3 so I just could hear the music from iTunes. And when I saw some stutters I registered (remembered) the time it happened and just concentrated on the music from iTunes, and there were no stutters att all in the music from iTunes. When I looked in in D3debug.txt the same "Disposing sound system..." was there every time it stuttered.

So it seems like D3 is redetecting the sound card or something.
Well the fact that system audio isn't cutting out is good at least. I would be interested to see what the disk I/O graph looks like while you are playing, also what the paging and memory usage is.

I've now played until I experienced the stuttering and took some screenshots of the activity monitor (sorry about the swedish, but I think you can figure it out anyway)

Memory usage:
looks fine to me, 0 pages out and 12GB free

Disk usage:
Also looks fine to me, only 30 I/O/sec as maximum during game session. ("lästa" = "read", "skrivna" = "written")

The spike I spoke of earlier doesn't seem to have anything with the stuttering to do since I didn't look at the scale of the graph and that it appears like 20 seconds before the stuttering sometimes.
Can you reproduce this with any other game, if possible make it not be SC2 as these both seem to share a pool of similar issues.

Join the Conversation

Return to Forum