Losing internet when starting Diablo 3

Technical Support
Maybe someone or a group of people are having this issue along with me.

I noticed this yesterday afternoon when I came in from walking the dog. I would open up Diablo 3 and my wireless would just suddenly go dead. I figured it was a one off thing and rebooted, that actually started the chain of WTFs that went running through my head.

I rebooted and ran a constant ping to google. Im fine with about 12-26ms to their servers.
I start Diablo 3 and I stop getting replies. Just from starting Diablo. As soon as I exit the game I get my connection back just fine. If I let it sit in the login menu I sometimes get a reply.

In the last 24-48 hours prior to this happening I have not made any changes to the computer, modem or any other devices between me and the ISP.

World of Warcraft works 100% fine and I dont get this issue.
I boot up Diablo 3 on another computer and its perfectly fine.

I have checked my port settings, wireless, nic settings.
I have reset my TCP and netsh stacks. Along with all internet devices
I have deleted the crap in C:\ProgramData.
I have updated my drivers for the nic and even reinstalled.
I have rebooted
I have ran tracerts while in game and out of game just so people wont bother asking about that. If you need to ask, I cant get 1 hop while in game, but can complete hops while out.
I have monitored my wireless device in the event it could be that but I have on average an 88% connection through out and nothing on it changes

Running Win 7 x86
Intel i7 @ 4.02GHz
6Gig DDR3 Ram
GTX 580
Gigabyte X58A-UD3R mobo

I work IT and have done it for a good while, I tend not to overlook things while trouble shooting, but for the life of me I can not figure this out. I seems to be isolated to my computer as I can play Diablo from the wifes on the same network with 0 issues.

This has happened before about maybe a month ago and i have tried applying the same fixes I used then to get it to work but that was mostly a routing/switching problem (complicated network here >.<)

Any help would be great, even a blue post, but its blizzard and not expecting much.
Fixed

I don't think the router held its old firmware upgrade somehow and rebooted. Searched through the logs and verified a random reboot and the firmware was not up to date.

I have managed to upgrade the routers firmware again and it seems to be holding stable and I can actually log into the game on this computer along with all the others in the house hold.
Hey Systemkaos!

I have the same problem you do, but it seems my router does not have firmware upgrades (inteno EG101-R1) and even on their website they do not offer any help on firmware.

I've been playing D3 problemfree for awhile and i'm wondering what just changed blizzard?!

Since i seem not to be able to fix this on my own, anyone out there with a suggestion? or is the safest way just go and buy a new router? (seems like a !@#$ty fix for a game that worked perfectly before yesterday).

// Moz

Join the Conversation

Return to Forum