Patch loop/taskbar issue

Technical Support
I'm trying to get on Diablo 3 but I'm stuck in a patch loop. Last time that happened it was because servers were under maintenance so that's the first thing I checked.

I'm able to click on Play on the launcher but when I actually try to log in it says: "A new patch is available for Diablo 3. The game will now close and apply the patch automatically. You will be able to continue playing after the patch has been applied." The game just closes after that and a message is shown.

"Failed to launch "Diablo III Launcher.exe"!
Error 740: The requested operation requires elevation.

I'm also getting issues when I place the game on my taskbar. I can't right click it to change its properties.
I was able to right click on my taskbar's Diablo icon. I hit shift-right click and it worked. I removed the "Launch as admin" option. Now, instead of getting Error 740, the launcher just opens right back up when I click OK after seeing the "A new patch is available" message.

EDIT: However, I still can't remove the icon from the taskbar.
zed,

Go to Start Menu --> All programs --> Diablo III folder and then right click the Diablo III icon. Select unpin from taskbar.
zed,

Go to Start Menu --> All programs --> Diablo III folder and then right click the Diablo III icon. Select unpin from taskbar.


I have no such option. I went to the actual Diablo III folder as well as the Start menu and there is no "Unpin" option. I only see "Pin to taskbar"

I'm also still getting the patch loop :(.
I managed to get it off... I clicked on the taskbar icon and got a message saying it was deleted/moved etc... and it asked me to take it off of the taskbar.
zed,

For the patch looping, try deleting the Diablo III.mfil file in the main Diablo III game folder along with the Updates folder, then run the game again.
zed,

For the patch looping, try deleting the Diablo III.mfil file in the main Diablo III game folder along with the Updates folder, then run the game again.


That did not work. I'm guessing those are files that recreate themselves? When I launched Diablo, they did not reappear in the folder.

EDIT: It's not the first time I've seen issues like this. I had transferred my WoW folder from one hard drive to the other and it had caused issues with my game. All I had to do was launch WoW in administrator mode and it fixed itself. It doesn't seem to be working for Diablo.
zed,

Ok, give the following two articles a try next please.



That second one fixed it. Thanks a lot for your help. :)

Join the Conversation

Return to Forum