Error after patch 1.06

Technical Support
After i updated to patch 1.06, when i try to launch the game the launcher freezes and i don't even get to the login screen. Is anyone else experincing this?
same here!!!!! What to do?
Same thing happens to me. I have not even been able to play this game even once on this brand new PC I just bought.

I just recently purchased a brand new desktop PC with Windows 8 and after installing Diablo 3 and updating to patch 1.0.6 or whatever the newest version is as of 11/29/12 and this game DOES NOT WORK AT ALL!!!!!

I click the play button and the Diablo skull with Diablo III written across it shows up and then it just sits there forever without loading into the game.

My PC specs are AMD A8-5500 APU with Radeon(tm) HD Graphics 3.20 GHz
6.00 GB RAM Windows 8 64 bit obviously....

Basically this PC is an HP Pavillion p7-1414 PC model number. Doesn't make any sense seeing as how my "gaming" PC loads the game instantly each and every time I want to play it.
Same Here Please Help us Diablo 3 Support Forum Agent Your Comments Will Help us to solve our problem asap.
Same here! But I don't even get the updates
Error: BLZAPPBTS00007
Already waited some time, tried agian, and already restarted the PC. Wondering if I'll have to reinstall the whole game...
Ok, here I tried both. It did restart the updating process this time during the Launcher, but it got stuck again and reported the following error:
Error: BLZAPPBTS00007 - Failed to Run a Required Program (Agent)
which by the way is the same as before :/
Hello,

After installing the patch 1.0.6 yesterday, I am unable to play d3. :(

I don't have a problem with my net. But after installing the patch, all I am getting is the error message below.

"Failed to start the streaming download. Please check your internet connection and try again."


Please help.

Thanks!

Join the Conversation

Return to Forum