1.0.6a and Error 3007?

General Discussion
Prev 1 20 21 22 25 Next
Beijing China. can't log in after 1.0.6.13644 updated.
Darwin, Australia. can't log in unless i change DNS server... and when i do, i LAG like crazy (and, essentially can't play)
We all lag no matter ur connection/isp or DNS server.
As far as Bliz are concerned Aus/Nz is the Red Headed Stepchild they locked in their basement.

If you still can't login then you can wait till ur isp receives dns refresh from bliz(the settings they say they didnt change but they really did change and that caused all these problems) or you can wait happily bent over a barrel and smile =)

BTW- You can always use the workaround provided at the start ;)
Hi all from another guy in Australia, Only getting the (Error 3007) for the American server Asia and Europ log in fine. Thank you for your latest patch 1.0.6a.13644. Finally I was able to update instead of getting the bogus check your connection error, good work.
3 days and still nothing???

Change your DNS to googlesie. 8.8.8.8 for primary and 8.8.4.4 secondary


Aside from being computer illiterate, I shouldnt have to change settings on my computer when the game WAS working before hand.

I was thinking of getting the WOW games, but Blizzard has treated this game (in my view) with such disrespect, I dont think I will spend any more money on their products. I will probably still play this game when it works, but aside from that... meh.
12/12/2012 05:14 PMPosted by NevahDie
hey lylirra how about any sort of update....your patch notes for your hotfix/fastpatch must have been lost somewhere, i only saw one thing that should not have taken 11 and a half hours.....i mean really....so whats the good word? any word of bashiok getting his job back? at least that kid was honest and straight up about rmah and ah controlling drop rates....they just dont make gms like they used to huh.


First of all, you should finish High School English classes before criticizing anyone.

Second, you're an idiot if you think Bashiok was even remotely serious. Did anyone ever teach you about this thing called "sarcasm?" If you think the Auction Houses control drop rates in any form, you need to be lobotomized.
yeah....i too am from Australia...trying to login US server...kept showing ERROR 3007 :(
same here mate~!
Still broken.. Epic fail

Brisbane Australia here
Aussie player-Melbourne....Still have error 3007....
Sydney, attempted to log in failed.
Well .. I can confiirm that my ISP's (being iprimus) dns does work, however I have used googles free dns since the patch and the problem's that I had with it.

Ok now here is a DNS LESSON FOR ALL OF YOU. (plus a little bit of - wtf, get off your lazy !@# and learn/do something for yourself for once)

If you are *still* having problem's, just bloody change the freakin dns to google dns, the fixes were posted within hours of the situation even occuring, after some time your isp's dns will pickup the changed/correct diablo addresses by itself - YOU WILL NOT NEED TO DO ANYTHING. Give it time (ie 12h/1 day) after you change it and then change it back.

And that's it, the fix it simple, just have the sense to try and learn to do it, its not hard.
Ethiriul i did get off my lazy @@@ and tried that and it still didnt fix it and i still cant log in, we shouldnt need to fix our end ...
elthiriul,i changed my dns to 8888 and yes i can log in,how will i know the problem or whatever happed is fixed so i can change it bak to auto settings?
so i just change it back after a day or so,sorry im not real good with computers lol but hey,if i can change my dns to work,anyone can lol
looking deeper, I suspect the DNS error is AT&T's fault, not Blizzard's fault.

This is broken (using iiNet's DNS which has cached a bad / stale record):
$ host us.depot.battle.net
us.depot.battle.net is an alias for wpc.758c.att-acdn.net.
wpc.758c.att-acdn.net is an alias for gs1.wpc.edgecastcdn.net.
gs1.wpc.edgecastcdn.net has address 68.232.45.253

This is the correct version, using Google's DNS.

$ host us.depot.battle.net 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
Aliases:

us.depot.battle.net is an alias for wpc.758c.att-acdn.net.
wpc.758c.att-acdn.net is an alias for site-rrc--grp-ldr--gc1.wpc.nossl.ms.na.att-acdn.net.
site-rrc--grp-ldr--gc1.wpc.nossl.ms.na.att-acdn.net has address 12.120.152.128
so what do we got to do change !@#$ in our net setings seams like a lot of %^-*n around to me im no good at changing !@#$ im in nz mayb thay should make a server for our side of the world so we dont have this problem agane
It's none of 'our' problems, it happened after the patch and now blizzard says there's no problems on their end so wtf? I, among many others are not going to change settings to suit the game when it worked prefectly prior to the patch.

Join the Conversation

Return to Forum