Game won't launch on Mac after 1.0.6a

Mac Technical Support
The launcher overlaps and brefly updates the game. When I click Play, the Diablo icon pops up and freezes. I used to have the same problem once in a while, and fixed it by deleting Diablo III.tfil and Diablo III.mfil files. But this time it doesn't work. Please help.
Does it ever crash at this point and present a error report ID?
I don't know if I should start a new topic but I have the same problem here; just updated the game, it says the game is up to date, when I hit play it gets stuck at loading screen with Diablo's face on it, the beachball of death spins forever. When I force quit it, it gives me this code D10E1838-128A-465B-A08D-1D408AE1C0C5. I also used to delete the Diablo III.tfil and Diablo III.mfil files but it doesn't work this time for me either.

-I tried again while writing this and this time I got 0832D7E4-2CED-4B32-98BD-46B020E5F58C.
Looking at the crash report, it looks like it is still a bad Diablo III.mfil file :(

Do me a favor and open your Diablo III.mfil file and copy/paste the contents. You can open it with TextEdit.
+1

I have the exact same problem, however i'm on a PC instead of MAC. Tried a couple of previously-working solutions, such as killing the agent32.exe through the task manager, deleting mfil/tfil files, updating FX driver, etc. But the problem seems to be persistent this time. I simply can't launch the game. A solution which also includes me would be greatly appreciated.

Thanks in advance for your concern.

PS. The content of my .mfil file is as follows :

"version=2
server=akamai
location=http://dist.blizzard.com.edgesuite.net/d3-pod-retail/EU/8370.direct/
server=limelight
location=http://llnw.blizzard.com/d3-pod-retail/EU/8370.direct/
manifest_partial=d3-13644-3FACB8252A466A31AD5BE50DFE285EFE.mfil"

PS.2 If i ever wait long enough to see whether the game crashes or pops out an error message i am getting a Streaming Failure message.
Do you get an error report ID as well, so I can see if it is the same issue? This specific issue as far as I knew was Mac specific in my research.

I am also curious, what happens if you switch your DNS server to a different one, like Google's public DNS server?

This helped others who had this issue before we found out it was a bad mfil file.
Well hello,

Here is the content of my mfil file:

version=2
server=akamai
location=http://dist.blizzard.com.edgesuite.net/d3-pod-retail/EU/8370.direct/
server=limelight
location=http://llnw.blizzard.com/d3-pod-retail/EU/8370.direct/
manifest_partial=d3-13644-3FACB8252A466A31AD5BE50DFE285EFE.mfil

And here is the error report ID:

C2BF880C-DA2F-4865-A8EE-B5AE91C5AAC9

Alright. I solved it. I was using google dns, and I cleared it to normal dns and it worked. However it does not fully make sense to me. The game is working, but could you still look into this?

Thanks
Can y'all post some system specs as well? This will help us out in researching this issue. Thanks!

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
The report ID I got this time: 9268E03A-7FDF-4C60-9983-B6C78DE0200F

Here's my content of the mfil file:

version=2
server=akamai
location=http://dist.blizzard.com.edgesuite.net/d3-pod-retail/EU/8370.direct/
server=limelight
location=http://llnw.blizzard.com/d3-pod-retail/EU/8370.direct/
manifest_partial=d3-13644-3FACB8252A466A31AD5BE50DFE285EFE.mfil


and the system specs:

Hardware
Model Name: iMac
Model Identifier: iMac11,2
Processor Name: Intel Core i3
Processor Speed: 3,2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache (per core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB
Processor Interconnect Speed: 5.86 GT/s
Boot ROM Version: IM112.0057.B00
SMC Version (system): 1.64f5
Serial Number (system):
Hardware UUID: 4200BB52-6631-5960-A104-92ED378788C0


Graphics
ATI Radeon HD 5670:

Chipset Model: ATI Radeon HD 5670
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x68c0
Revision ID: 0x0000
ROM Revision: 113-B9850H-133
EFI Driver Version: 01.00.416
Displays:
iMac:
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort
Display Connector:
Status: No Display Connected


Software
System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: iMac HD
Boot Mode: Normal
Computer Name:
User Name:
Secure Virtual Memory: Not Enabled
64-bit Kernel and Extensions: No
Time since boot: 55 minutes


I'm using OpenDNS, I'll try with the default DNS or Google DNS and report back. I must say that this issue occurs every time after a new patch is introduced.

Update: The default DNS worked. I guess I'll have to switch DNS settings each time I play until this is solved.
This is stupid. I always have to workaround, clesr an mfil file, switch DNS and so on. Now nothing is working. The game wont launch no matter wht I did. Can you please try and fix this? Its embarassing really.
I've got word back.

Based on the troubleshooting information provided, it sounds specifically like an ISP issue.

One other potential option to request of the user would be to run the Repair option built into the tools now.

Can you try that?

https://us.battle.net/support/en/article/repairing-blizzard-games

Join the Conversation

Return to Forum