Diablo 3 crashes immediately on "play game"

Technical Support
So my diablo 3 was working fine this morning and now it continuously crashes when ever i hit play game.
I have repaired and it did nothing, i also reinstalled and that did nothing.
Also there are no error messages or anything.
Kaylyth,

Didn't we just fix an issue for you in World of Warcraft?

Reinstalling is fine but it doesn't replace two existing folders that could be causing trouble.

Could you try what's described in the following two articles please?

https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS

https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS
Yes you did Omrakos, i was having problems with my graphics, also i fixed it already, not sure how but i did but i will bookmark this incase it happens again
So yeah, the problem started again and i did what you said and its still crashing. I believe how i got it to work before was to clear preferences sit through the cut scene and it worked but as soon as i tabbed out and back in it crashes and started crashing on start up again. Really dont want to reset preferences all the time, any suggestions?
Kaylyth,

I need some indication of what you mean by it's "crashing". An error code would be helpful. If you don't see one, I'll want to see your D3Debug.txt file. It's located in the main Diablo III game folder. Edit out your account name first though. It's going to appear in a few places in the file.
okay, if i start the game without resetting preferences or tab out after reseting them the screen goes grey and i get the windows 7 thing saying something like, diablo 3 retail has stopped working: a problem has caused diablo 3 to stop working we will let you know if we find a solution

My D3debugg

I've looked through it three times now and dont see my account name anywhere so im hoping its not there as i cannot see it but because im peraniod im going to edit out the whole thing after your done if thats alright

[removed]
Kaylyth,

How are you resetting or clearing the preferences?

Can you post the D3Prefs.txt file?

It's located in the My Documents\Diablo III folder.
i reset it in the loader of the game, under the options part

PreferencesVersion "44"
PlayedCutscene0 "1"
PlayedCutscene1 "0"
PlayedCutscene2 "0"
PlayedCutscene3 "0"
DisplayModeFlags "0"
DisplayModeWindowMode "0"
DisplayModeWinLeft "0"
DisplayModeWinTop "0"
DisplayModeWinWidth "1920"
DisplayModeWinHeight "1040"
DisplayModeUIOptWidth "1920"
DisplayModeUIOptHeight "1080"
DisplayModeWidth "1920"
DisplayModeHeight "1080"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "1.000000"
MipOffset "0"
ShadowQuality "5"
PhysicsQuality "1"
ClutterQuality "3"
Vsync "0"
Letterbox "0"
Antialiasing "1"
LowFX "0"
LimitForegroundFPS "1"
MaxForegroundFPS "150"
LimitBackgroundFPS "1"
MaxBackgroundFPS "8"
DisableTrilinearFiltering "0"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "4"
PCIVendor "4098"
PCIDevice "26685"
MasterVolume "0.100000"
EffectVolume "0.800000"
MusicVolume "0.800000"
NarrationVolume "0.800000"
AmbientVolume "0.800000"
ChannelsToUse "32"
SoundDriver "0"
SpeakerMode "0"
ReverseSpeakers "0"
QuestSubtitlesEnabled "0"
CinematicsSubtitlesEnabled "0"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
MuteMusic "0"
Kaylyth,

All that does really is delete the D3Prefs file so the game uses default settings when it runs the next time. The file is saved with any changes you make when you exit the game after that. What changes are you making if any?

Also, are you getting far enough after resetting them to see the opening cinematic start up?
i set the master volume down to 10% after reseting them and it runs as long as i need it to but if i tab out of the game and back in it crashes again
Kaylyth,

Ok, don't reset the preferences any more but make these changes to the existing prefs file and see if it helps any.

Change these lines:

DisplayModeWindowMode "0"
Vsync "0"
LimitForegroundFPS "1"
LimitBackgroundFPS "1"

to

DisplayModeWindowMode "1"
Vsync "1"
LimitForegroundFPS "0"
LimitBackgroundFPS "0"

I'm leaving for the day in about 5 minutes so I'll probably not be able to reply again until tomorrow when I get in around noon PST.
it did not help but thank you for being amazing and bearing with me, ill check this again tomorrow. Have a pleasant night.
Any help?
Kaylyth,

Let me get your dxdiag info.

You can find this information in the Direct X Diagnostic Tool:

Click on Start
Click on Run
Type in: dxdiag (In Vista, type dxdiag in the search field)
Hit Enter or OK

Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

Join the Conversation

Return to Forum