so disappointed with error 3007

Technical Support
so... i've been waiting for a year for this problem to be fixed... (well more acurately since before christmas and technically its 1 year). i have no idea why, i tried most of the fixes i found on the forums... i even broke one LAN Card in the process... but still i can't connect to Americas Region. ever since i upgraded my account to standard edition, I've only played the game TWICE with my cousins... yes TWICE... the only reason i bought the game was to play with them while we all still free time. tried sending a ticket and received a reply that didn't help at all... so... will there anyone out there be able to help me?

P.S. ~ i have no problem when connecting to Asia/Europe Regions...

~oh and one last thing... pls don't bother saying to switch Regions... if that was a viable option, wouldn't have posted here anymore... thanks very much and i hope everyone of you had an awesome holidays!!!
It sounds like you had the same problem that I was having. I was only able to connect to Europe and Asia's servers, and when I tried to connect to the Americas server I got Error 3007.

After much searching I found this solved my problem. I manually selected the google DNS under your connection properties.

To do this, follow these steps. Works for Windows 7 (unsure about other versions)

1. click control panel
2. click network and internet connections
3. click network and sharing center
4. on the right hand side of the window you should see a link to local area connections...click that
5. that opens another window, click properties in the bottom left of that window.
6. select Internet Protocol Version 4 (TCP/IPv4).
7. Click properties
8. Choose the bubble that says "Use the following DNS server address"
9. Fill in the boxes next to "Preferred DNS server" with 8.8.8.8
10. Fill in the boxes next to "Altenative DNS server" with 8.8.4.4
11. Click okay and close all that stuff out.

This should solve the problem.

Join the Conversation

Return to Forum