[HELP] Authentication Error 14404

Aus/NZ General Discussion
Thanks for the idea Timmoi,

Will test tomorrow night after work to check that.
I didn't notice that through clicking a hyperlink from my e-mail changed it from "http://us.battle.net" to "http://sea.battle.net" (I am assuming that's got to to with other Blizz games, such as WOW/Starcraft using battle.net)
Although i didn't really wanna have to create an entirely new e-mail address for D3.

Also...

I have edited the text above in my original post to include who I am.

Me here>>>>>> http://us.battle.net/d3/en/profile/LameSalad-6914/

^^^^^^^Thats me.

(Thankfully i can see myself through my room mates account friends list, and i can see i still have my gear that i was wearing, on all of my characters, so that's a good sign no-one has robbed my characters items)

Thanks for the reply,
Glad to see the community coming through with some possible alternatives for me.

When i get back on, i will come slay some minions with you =~)

Cheerio, and back to YouTube videos (for now)
I checked on the EU forum (eu.battle.net/en) and found what looks like a solution:

"I had the same problem but reading the posts here i found a way to make it work. My account is on US bnet and im playing on EU servers. When i try to log in EU servers i got the error but i could log in the US servers np. So to be able to log into EU servers i had to accept that agreement or wth blizzard wanted. The solution is this : Log on Asia , EU , US , and see where the agreement pop-up and accept it. After you accept it you can log in where you want. For me it poped on Asia server ( lool i never played there and my account is US but ... ) . Try this method and post here if it works for you too."
So, only sollutions I have seen so far are that "DNS change one" and changing servers and accepting the agreement. Our problem is, On computer 1 - I log in under my account on the 3 servers - EU, US and Asia and I do not get that error message. I change the account and use my sons' one and I can only log in on the Asia and EU servers and i get the "There was a problem with an authentication module, error 14404" when i connect to the US server. I have tried that changing server to Asia and Eu and then logging back into the US one, but it doesnt work. I have already accepted the agreement when i logged into the Asia server, and it doesnt pop up anymore on the US or EU. what else could be wrong? It does the same on all 3 computers in the house. I can log in on all servers under my account, but can only log in on the Asia/EU server under my sons' account. Shutting down all comps and restarting modem router doesnt help either. I didnt think it would anyways since I have no problem logging in under my account, only my sons' one.
This worked!!!!!! (timmoi)

Thankyou thankyou thanku =)
added you as a friend whenever you wish to slay some demons with me now im back online, Thankyou once again!
Had this problem for a couple of weeks. solved by this awesome chap =~)

(Timmoi)

Hey getzangry

I had the same problem resetting my password last week, try changing the bit where it says "http://sea.battle.net" to "http://us.battle.net" in the email URL (you'll need to get a new email generated first). You'll need to copy and paste the link address into your browser, then change the letters :)
SeeNLiNx do you know how t o do a trace route? if so next time it isn't working run one to see where the connection is being blocked.

All those errors are connection errors and while it can happen at blizzards end, the fact it seems very very random for you suggestions it could be the routing your net is using. or a home firewall/antivirus program perhaps?

I mean I've heard of all these errors before and know blizzard have faults with them, just your case seems a bit more bizarre then the norm.


Yeah i know how to do a traceroute can post the results here again tonight when i'm home (as i've done three times before trying to get an answer to no avail)...no it's not the firewall or antivirus prog - turned them off to no avail, turned them on again to no difference.

As i keep saying these issues only happened after the recent updates..i dont understand how (usually after multiple attempts) i can log in, only to have no auction house or the game then wont allow me to change chars, continue my game or basically do anything that you'd expect to do on a game you've paid for.

Interesting how i can play any other game i try online...ONLY D3 is the problem - judging from the continuous posts i'm not alone either.
timmoi you are an absolute legend, i have been locked out for days and have finally been able to get on thanks to your advice.
I play on a laptop and tried to log on at my brothers place and got locked out for suspicious activity. got that damn error when i tried to password reset. Now i can get back to slaying a few beasts and its all thanks to you.

Top marks!!!
Hi everyone

For those unfortunate players getting this auth issue. Try changing your server to EU, if it doesn't work try using Asia server. That's how i fixed this issue. I'm sad about getting lots of issue even when i first started playing this game. The customer support once told me to wait for 3 days before i can log in. Fortunately i called again and landed with a skilled support after waiting for 38mins that i only needed to change my password. =(
Why hasn't blizzard commented on this yet? Are they serious?

I stopped playing the game about 9 months ago at around 1.0.3 patch, it was boring. Come back to see whats new and buy a copy for my girlfriend and she's getting 14404, spent all night trying to fix it...

This shouldn't be happening this far into the games life.... honestly, just really poor form.
Guys,

My mate just had this problem and fixed it by changing his battle.net password. Apparently the game can sometimes bug out when this occurs?

Just wanted to put this out there as the error annoyed us for about 2 hours before we found out this simple, and not obvious, fix.

Cheers,
Yes I totally agree with you SKORPIQN. Really poor service indeed. All fixes mentioned concerning this error does not work for our end. As I have mentioned before, on all 3 computers in our household, I can log in on ALL SERVERS - EU, ASIA, US from my account. Only my son has the "error 14404" problem when logging in from his account on the US server, he has no problem logging in on the EU/ASIA servers and that is on all computers in the house hold. We have tried changing his email address, changed password, dont need to do that use google DNS as that should not be the problem here since I can connect no problem to all servers on my account. Now c'mon BLIZZARD give us a more definite answer to what is causing this problem and an ETA on a fix for it!!
The whole sea or us website thing has been causing issues for awhile now. Good news is that with HoTs being released soon and global play coming in for SC2 a lot of the features of the sea site are being merged with the us site. I hope this fixes the problems.

I've spoken with blizz about the 14404 error to have it looked into further, I agree it is pretty poor that the issue hasn't been found as yet and we are playing the guessing game.

Good to see people are getting it working though.
________________________________________________
Twitter: @Narull | ANZ Diablo III MVP
http://us.battle.net/d3/en/forum/topic/6490399005 - Narull's Hardcore Challenge.
http://www.blizzposts.com - Keep track of all Official Blizzard posts.
There not spelling mistakes, Im speaking 'Ye Old English'
@ Cruzonova

Try the DNS change and turn off your authenticator, that's what worked for me.... finally.
Had this problem for a couple of weeks. solved by this awesome chap =~)

(Timmoi)

Hey getzangry

I had the same problem resetting my password last week, try changing the bit where it says "http://sea.battle.net" to "http://us.battle.net" in the email URL (you'll need to get a new email generated first). You'll need to copy and paste the link address into your browser, then change the letters :)


How to do? I have same problem but I do all way it no work for me.Help me plese!
I have same error 14404 authentication module
how to change http://sea.battle.net" to "http://us.battle.net"?
@SKORPIQN, tnx for that reply, but as I have mentioned in my posts that I am able to log in under my account, only my son is having the problem, and thats on the same computers in the household. if it was a DNS problem, shouldnt my account be affected as well as we are both using the same computers/connection?

@Narull
Ty bud. Yes lets hope that these issues, mainly connection issues gets resolved b4 HoTs gets released. Pretty much the only other game I really enjoy from blizz is SC/SC2.

Yes I agree, glad to see some people are getting their error 14404 problem sorted and can actually get into the game and play it. Congratz!! Now for the rest of us, guess its just a waiting game now, a bummer, but I guess its life aye.
It must have something to do with having an authenticator and being based on one region but logging into another.
all i wanted to do was play diablo 3 first day i got it,,,,,, error why does this happen to australians /nz it seems only like hey you know what lets just screw around with anz people whenever we release updates YAY D: ive been looking at other threads related to australians errors since patches and there is more than i can count so please blizzard fix this !@#$%^- problem im sick of getting errors after patches!
stupid
wow that time it didnt have random capital numbers btw i typed stupid in those random cap numbers :D

Join the Conversation

Return to Forum