Stuck at "Updating Blizzard Update Agent"

Technical Support
Such as the title says. I've been stuck here all day, and even after coming back at the end of the business day I'm still seeing the same thing.

OS: Windows 7 x64 SP1

I've already run a trace route to the America's D3 server if it needs to be shown.

Could you try what's described in the following two articles please?

If it doesn't help, since it appears you're playing from a campus, it would be helpful to know if any other students playing the game there are having similar problems.
Both attempts have failed. I even resorted before and after deletion.

So far it is only me who is having this issue. I can connect to WoW and SCII just fine though.

Connecting to Wow or SCII will do the same updating of Agent that Diablo III does. Can you verify either of those two games are still functional and if so, try Diablo III again? When started, they all check and update the same Agent files.
Yup, they're doing just fine. Diablo III is still having trouble.

Try starting Diablo III with the "Run as Administrator" option. To do that, just right click on the icon you use to start the game and that option will be listed.
Nothing so far.

Ok, could you navigate to your C:\ProgramData\\Client\Blizzard Launcher.1949\Logs folder and delete the file called "Blizzard Launcher.log"?

Then try starting the game up again. I assume it will fail again and when it does, please post the newly created "Blizzard Launcher.log" file from the above location.
There appears to be no logs folder.

Is there a "Blizzard Launcher.1949" folder? It ought to have 14 entries inside, 3 of which are folders.
Only one folder.

Gyazo is an instant screen cap program, the image is of the Blizzard Launcher.1949 folder.

Sorry for the delayed response, I had a family emergency that needed to be tend to.
Still no help or anything. D:

Logging into Wow or SCII should be adding to the log file I mentioned above. Are you sure you're able to enter those games all the way? Or is there another launcher version folder where you see Blizzard Launcher.1949 listed? Perhaps one for 1640? If so, see if there's a Logs folder inside it with the log file I mentioned.
Yup. I was doing RBGs the last few days and I was able to hop onto SCII.

The other folders do not exist either.

Use the Windows search utility and see if you can find the file "Blizzard Launcher.log". (without the quotes)
Still nothing. =/
I got stuck here too. I did a combination of two things.

Followed these steps on the support page: Update Agent (Agent.exe) Issues
Issues with the Agent helper program may prevent Diablo III from installing or updating properly. If you notice your installation hanging at Updating Setup Files, or if you receive errors specific to Agent, try the following steps:

- Stop the installation process if it’s still running.
- Wait for at least one minute. Ensure that Agent.exe no longer appears in the Processes tab of your Task Manager.
- Restart the installation.

That got me to the actual launcher, but up popped another error. "Failed to download required file."

This site helped:

Basically had to replace the "Diablo 3.tfil" file and it worked~
Fix for this

- Right click on Computer under the start menu
- Select manage
- Services and apps
- Services
- Find Secondary Logon in the list
- Right click
- Properties
- Drop down menu to Automatic

Bankmain fixed My issue as well although I had done it before I had since reinstalled my OS since then and forgot the procedure to turn back on secondary Logon as I have a optimization program I run every time I reinstall windows that turns that off as im the only user on my computer so it being on is waste of resources.
I finally am able to make this work. Only issue is that everything I had on the AH, as well as my unsold auctions is now gone.

How would I go about getting this fixed? I tried to submit a ticket, but it said that "these types of requests cannot be processed at this time."

Join the Conversation

Return to Forum