bashanishu

Bug Report
ho provato piu di una volta a compiere l'impresa bashanishu! ho provato addirittura impugnando 2 spade di rakanishu contemporaneamente e con diversi pg! ho addirittura ucciso bashiok con un colpo ma niente l'impresa non me la da!è possibile convalidarla visto che l'ho ripetuta piu volte e far apparira bashiok non è molto semplice?
"i tried multiple times to get the bashanishu achievement! i even tried to dual wield 2 rakanishu swords and with multiples charachters! I even killed him with one strike but no, the achievement won't go for me.is it possible to get it validated(not really sure about this) cause i repeated this lots of times and making bashiok apper it's not really easy?"

fast translation
I believe it only works with an old Rakanishu's Blade [Legacy] that dropped prior to patch 1.0.4.
02/13/2013 11:44 AMPosted by Liogela
Lo siento, pero solamente hablo una pequeña Espanól y no Italiano. Hablá Inglés si posible, por favór.

02/13/2013 07:05 PMPosted by Liogela
Thanks Django. We've tested this achievement internally several times now without reproducing any issues, so I'm pretty confident it's because he wasn't hitting with a basic attack.

Props to Liogela. In so many months I hadn't seen such a devoted representative on this bug forum. Trying to speak another language to accomodate the user? Actually testing the reports and giving feedback in real time, on multiple threads? It reminds me of the old Blizzard I used to think of... and I'm pleasantly surprised.

On the last two days, this forum section received more blue posts than in any other given whole month. I hope this lasts. Makes me actually feel like helping out and answering the posts I know the answer to - a feeling that was long gone by the lack of presence and feeling of abandonment that once ruled this place.

May the force be with you. Or, in Diablo's terms... May your will not falter.
02/13/2013 12:41 PMPosted by Raja
I believe it only works with an old Rakanishu's Blade [Legacy] that dropped prior to patch 1.0.4.


You are correct. A friend of mine found that guy in nightmare and i stripped most of my gear off my inf DH till i did a few hundred damage, i hit him once each with about 15 diff Rakanishu Blades and finally got the achievement when the same friend lent me his old blade from before 1.0.4.

Please fix this bug, some of us would like to complete the achivements.

I have a similar thing with Fecklar's ghost, done festering woods over 400 times not found him once.
I found out something a long time back. The sword can become bugged. So it is good to have several copies of Rakanishu Blade when finding bashiok. One sword didn't work; second one did -- same attack.
I had the skill swapped out so i was attacking with the sword.
I can confirm that Raja and Sparzy666 are correct. The achievement is bugged with newer blades. Only those older than 1.04 work. It happened to me and two of my friends. Only when I found an older blade was I able to complete the achievement. And trust me, I was using the basic attack the whole time.
Got the achievement last night with a 1.0.6 blade, maybe some blades drop bugged and some don't?

Never mind I was using a blade from the AH so I don't know what patch it was.
To explain the small issue we discovered in the data, the achievement is authored with an "and/or" argument. To paraphrase: "(Power is a basic attack AND weapon is a legacy blade) or (weapon is new blade)."

What we actually originally intended (which may change in the future) was: "(Power is a basic attack) and (Weapon is a legacy blade or new blade)."


I still don't understand this. From what you say, it should mean that with a new blade, the achievement should be earned every time, no matter what type of attack one is using. If that was the case, no one would have complained after that patch, as the achievement would've been even easier to earn.

I can definitely confirm I haven't got the achievement with a new blade.

Probably that logic statement is somewhat different then what you said, like say: "(Power is a basic attack AND weapon is a legacy blade) or (weapon is new blade AND ?)."
I was able to get the achievement just now, where i could not before when i tried in 1.0.5.
I used the new blade that dropped, with an empty socket.
I ran around with the blade in my left hand, and a 300th spear in my off hand for movement speed.
Basic melee attack on the left click, tempest rush on the right click..
When i found bashiok, i took off the off -hand weapon.
I hit him just the same way as when it had failed, with a basic attack.
This time it worked! Sorry for those still having trouble, I would be glad to trade you my blade if you want to try it.
Oh come on! Don't say you actually found him and killed him? Let him stay alive for a while and invite people who still needs the achivement plz (like me)
bungan i sent you a friend request

(edit no hes not dead yet, its on normal mp10 so far 4 people have got the achiev)

Join the Conversation

Return to Forum