Error 3003 / Unable to update tools

Mac Technical Support
I've tried and searched for every solution available but none worked, some solution(the one about deleting battle.net cache) even worsen my situation that I can't even get to the login screen. Now it just get stuck at the launcher screen with the Play button grayed out and eventually "Upable to update tools" came up.

* I've tried deleting cache, changing to google public dns, etc
they wont work, im at my wits end please help.

I stay in Singapore and im connecting to the americas server
I'm also experiencing this, changing the regions didn't seem to help me any though. Is it possible since i'm using a business offices internet the firewall is stopping me? Regardless how can I fix this..I need my diablo fix, jerks.
I'm also having a hard time logging in, I click play on the launcher and i get a brief glimpse of the login page then, POOF, its gone. the icon still shows in the task bar that the login page is running I just cant access it. Now WoW and Starcraft2 both work perfectly no problems logging in at all, it's just Diablo3. Ive been all over the trouble shooting forums and its really not helping.

Join the Conversation

Return to Forum