Bought gold off the RMAH, says claimed.

Technical Support
So I just bought 70m worth off the RMAH this morning, which was said to be processing. So after I get home from my studies I check the RMAH to see if the gold has come through. The status of the order is claimed, which I have not claimed at all, so now I am down $17.50.

The order ID is 1394739597
MentalFloss,

I could be wrong in interpreting the status but I'm not seeing any indication at all that the gold was sent or claimed. The order is listed as "Failed". Another purchase that was made today is under "Manual Review".
I made another purchase to see if it would push the other amount into my account but it didn't. So the $17.50 didn't get accepted then?

What do I do about the Manual Review?
MentalFloss,

From what I can tell, you won't be charged the $17.50. The other order is just going through the normal review process which can take upwards of 72 hours sometimes. I can't tell the outcome ahead of time.
Ahh okay, thanks for the help :).
Just an update, the other auctions I have tried also did the same thing, they are marked as Completed and Claimed on the AH and I have not claimed any gold since it hasn't shown up in my completed list.
The same for me when i purchased 2 items, they become available to send to stash straight away, the gold i got is just sitting there with a review (!) on it, i think its just for gold when i read this.
That's not entirely my issue. The under review will probably take a while but I said I was getting the auctions showing as Claimed yet I have nothing in the completed items tab.
No luck as of yet, its abit stupid to wait 2 days and still no gold, can see why people use farmers, 2+ days or 2mins... haha i think thats how they think.
Yep. The auctions must be going through because the money for them has left my bank account.

Join the Conversation

Return to Forum