Surface Pro Mouse problem

Technical Support
As the topic says I'm trying to run Diablo 3 on my Surface Pro, but I'm having a serious issue when I start the game the mouse cursor stops responding.
The touch pad doesn't work, neither the external mouse I have attached. Has anyone seen this problem before? I couldn't find any information about this issue, so I'm using this as a last resort.
I have the same problem with starcraft II, However Touch does work in a limited fashion. Your mouse might be working, but the mouse pointer is not moving with the mouse. That is what is happening in SC2 on my Surface Pro
Well, I have no idea, what happened, but problem solve itself. I'm not a dumb guy or anything, but the whole thing made no sense. I restarted D3 a few times and it started working. Mouse works now, touch works as well, I can actually slide my finger on the screen and move the character around.

I read a suggestion from some forum and right click on the Diablo3.exe --> Properties --> Disable DPI something and run it again. It was a tip for SCII players, but I did it on D3, game was doing the same thing, but after few attempts starting D3 mouse and pad started working.
silentkiller,

There's an issue when using Windows Vista or later that can cause the cursor not to display in our games. If you've changed the text size from it's default value, the cursor may go away. Changing it back to default can restore it. This requires a reboot though so it's not very convenient. Enabling the "Disable display scaling on high DPI settings" option under compatibility in the properties for the game executable (or shortcut) can fix it too which sounds like what you probably did.
the "Disable display scaling on high DPI settings" made the touch pen thing start working. but the mouse cursor still doesn't move at all. turning off the text scaling isnt an option on the surface pro if you consider the size of the screen... is there a way to disable the hardware cursor? maybe that would help for now?
i found a hack for myself. idk how this impacts performance.. but i read that it happens in vista and later in the above blue post. so i tried setting compatibility mode for windows xp sp3 and the mouse works well now. please note i left the setting "Disable Display Scaling on High DPI Settings" checked and haven't tried it off.
Great, I hope these listed solitions help on other people using the Surface Pro. So far it does the job while on the road :)
Just recently reinstalled on my Surface Pro and the "Disable display..." worked perfectly.
just curious, how's performance on surface pro? Hell, I might buy one if it's not too shabby!
I had to disable the DPI setting and turn on the windows compatibility setting for Windows 8 for Diablo 3... then I was able to see the mouse cursor.
I have the same problem. The Mouse pointer disappears, but if I move the mouse around, things on the screen highligh just as if the mouse were rolling over the icon, but I cant see the mouse move. Same on Starcraft and Diablo 3
Old post I know... But I have been D3'ing on my SP2... The display zoom settings must be 100%, or normal... Surfaces have the Display set to 150% (Default) to make things easier as a tablet with touch... the larger zoom setting makes the mouse pointer disappear when you go into Diablo. To fix this:

Right click on desktop > Personalize > Display (lower left side) > click 100%/Smallest > OK/Apply... you will then have to log out of windows, then log back in.

If you have never used your surface in 100% display setting, you will notice everything is tiny, but when you go in to Diablo, your mouse is there. I haven't tested with 125% yet, as I am used to the 100% display setting now -- even in touch mode. Hope this helps!

Join the Conversation

Return to Forum