Error 10017: Error when creating the game?

Technical Support
Prev 1 12 13 14 25 Next
Lucky you i cant figure out who i last played with they logged off! BLIZZARD SHOULD HIRE ME
Didn't fix it for me, damn.
This is bs man this has been going on for a year now! can we get a blue on here to help us out i would really like to own some rifts!
10017... fix it please!
I'm getting Code 10017 when I try to create or join a game, along with the following message:

"Unable to join channel. You have joined the maximum number of this channel type."

I've tried the following suggested fixes:

  • Exiting the game, as well as the Battle.net app and restarting them.
  • Logging in with a different character.
  • Deleting the Blizzard Entertainment folder from C:/ProgramData.
  • Delete the Cache folder from \Diablo III\Data_D3\PC\MPQs and running the repair tool from the Battle.net launcer
  • Are there any other options I could try?
    I'm also getting the code 10017 when I try to join or create a game of any type.

    I've tried:
    Restarting the modem/router.
    Changing my password.
    Making a new character.
    Uninstalling and Reinstalling the game.

    Nothing has worked so far.
    Same. Tried all the methods, doesn't work.

    Even tried logging in on my Mac, same errors.

    Can't believe an error like this have been going around for a year and no resolution.
    Same errors. Blizzard need help...
    same to me please HELP ! ..
    This happens after a disconnect from a public game. God this is annoying.
    Im having the same issue on Eu servers atm after getting dc from a public game and quickly rejoining the game and the game started inviting players constantly even if we were 4 people.
    Just had this problem, restarting my PC helped!
    Having this Error nothing is Helping...Restarted my PC ,,restarted my router,,deleted everything pretty much other than the game itslef
    It is server side I think.
    Just got back into the game. I read somewhere that you need to group with one of the people that were in the group when the error occurs and have them invite you to a group and you should be able to get back in. it actually worked when he came back form being afk I got him to invite and I got right back in,, I have NO idea why that worked but im glad it did
    Have the same trouble, all my friends are good except me!!!
    Getting the same error. Happened when i left one game, switched characters, then tried to create a new game. I tried exiting, rebooting, and power cycling modem.
    Additionally, when i try and switch characters i'm getting error code 395002.
    This is what worked for me:

    Windows

    Close any Blizzard programs (Agent, game launcher, or game installer).
    Press Ctrl+Shift+Esc to bring up the Task Manager.
    Click the Processes tab.
    Select agent.exe and click End Process.
    Navigate to the folder containing the cache directory:
    Press Windows+R to open the Run dialogue.
    Type the following address into the Run window field and press Enter:
    Windows XP: C:\Documents and Settings\All Users\Application Data\
    Windows Vista/Windows 7/Windows 8: C:\ProgramData\
    If a Blizzard Entertainment folder exists in the directory, right-click it and select Delete.
    Relaunch the game using its normal shortcut or launcher.
    thank you awhelan

    It´s works!!!!

    Join the Conversation

    Return to Forum