Rubberbanding

Bug Report
With whirlwind...thought today's patch was supposed to fix it.

Nothing seems to have changed.

What's up?
Sad to read it was not fixed. Will test it tonite. Last night was embarrasing how many times I died during an uber carry because of this. Sometimes other players dont notice it and think u'r making up excuses.

Guess happy 1 year anniversary rubberbanding :(
great...still cannot play my HC ww barb. GREAT JOB! thumbs down
05/14/2013 01:56 PMPosted by ZaPLaS
Sad to read it was not fixed. Will test it tonite.


Would be interested in hearing your feedback after you test.
I've been playing since server came back and it appears no better.

I've been checking my latency @ time of incident and it doesn't appear to flinch. So unless it's a connection issue and the notification bar isn't as dynamic as it should be, than it's still an unresolved issue.
I am also experiencing rubberband issues after the fix(Whirl Wind). My MS is in the 90s at the times also.
It's still not fixed. I'm so frustrated by this - why does it seem new patches introduce more issues than their intended fix?
Same here. The patch did not fix the rubberbanding. Please REDO the fix! Properly next time!
+1 Fix Failed.. try again :(
Yeah i been talking about this in General discussion and i dont remeber this problem before the patch and if it was there it was every once in awhile now it happens 5-10 times a run and gets really old
BUMP

This is worse than ever.

I never used to experience this so frequently.

You're "fix" has introduced this problem to me and it's extremely frustrating.
Preemptive countdown until I hulk-smash my desktop due to rubber-band rage!!!!!!!!!!!!!!!!!

IT'S BEEN A YEAR GUYS, WHY HAVEN'T YOU SORTED OUT THE BASIC MECHANICS OF YOUR GAME?!?!?!

Join the Conversation

Return to Forum