Failing to connect

Technical Support
Greetings! I started a thread on the WoW Technical Support forums because I was getting the error #2

Because I also cannot connect to D3 (the launcher just sits there for a minute or two and then says "Failed to download. If problem persists contact customer support.") I figured I would ask here too since I'm pretty sure if I can fix the connection to one game, it would fix the other.

As you can see from the linked thread, I have tried resetting both the router and the modem, uninsalling AVG, turning off firewall, turning off windows defender, closing programs, etc.

The only new thing that I have tried was to delete the folder as per another support thread. That also didn't seem to work.

So if anyone has a fresh perspective on my issue and can shed some light on it, I would be most greatful!

EDIT: Oh yeah, and I flushed the DNS and opened up the wow ports on my router.
There are quite a few things that can cause this. Try the ones you have not done ...esp the one involving making sure IE is not set to offline mode. It is sneaky.

-Ensure your firewall or antivirus software is not blocking the launcher. You may have to temporarily disable it.
-Ensure Internet Explorer can access the internet, even if you don't use it as a browser. Be sure it is not set to work in offline mode.
-Ensure you have the latest version of Flash for IE, even if you don’t use IE.
-If you are on a campus or public facility some will block P2P software which is what Blizzard uses. In the launcher tools menu you can disable P2P, although this will slow patching time.
-Ensure Secondary Login service is enabled
-Ensure you are running as Admin
-Some third party software can interfere with the launcher so you can try running in Safe mode with Networking enabled. Beware your antivirus will be off if you do this.
- Sometimes odd things work such a DNS flush

If those do not work, you can try deleting the Tools and Cache folders to clear any corrupt files
Proxy Fix
Thanks for the reply MissCheetah! Actually, I have done all of those things except for the cache part. I'll give that a go now.

EDIT: Okay so I deleted the cache and it still failed to connect.
You even tried opening IE and connecting to the internet then running it? Not sure what else to suggest if you worked your way through the whole list.
Yeah, I have found out that if I use tracert to ANY website, it dies after the first hop. So, it's probably a problem with the ISP I guess. But since I'm visiting family, I really can't fix it. Oh well, thanks for your help anyway.
Ouch...yeah if that is the case then you can't fix it yourself. I thought you had issues just with the game, not the whole internet. I have a different list for that :) Enjoy your visit with the family! Maybe play some D2 if you have it installed.

Join the Conversation

Return to Forum