Unable to log you to battle.net - try again..

Technical Support
I can login fine with the battle.net beta -application, but when I try to start Hearthstone, I keep getting this error. Issue has lasted past 12 hours or so. Never encountered it before.

I am trying to use a test account for media, which I have been using to preview the game.
Fex,

Have you rebooted your computer over the last 12 hours? I've seen this symptom recently on my own system here at work and it was apparently being casued by an instance of "battle.net", the Desktop App, running in the background. Ending that process fixed it for me. Rebooting should work just the same for you.

You can also try reinstalling the Desktop App. If there's a "battle.net.exe" running though, you won't be able to uninstall it. That's how I found out it was running in the background.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Yeah, I've restarted so no extra copies of the Battle.net beta app running.

I'll try reinstalling it next.
That worked!

Although I accidentally had EUROPE as login region when signing to the battle.net app. I mean after reinstalling.

Well, everything good again. Thanks! :)

Join the Conversation

Return to Forum