Hearthstone hangs before loading

Mac Technical Support
Exact same thing has been happening to me since i got into the beta. I still haven't even gotten to play the game which is upsetting. I hope someone from blizzard replies.
same problem. another thing is when hearthstone hangs up my task manager also becomes unresponsive and i have to force reboot :( windows 8.1 asus n56vb
this is getting pretty annoying. game works fine one minute and becomes totally broken the next. i hope there's a solution for this
also same problem just got download today, trying to load through battle.net app and only goes to click here to start, music dies and then the game doesn't do anything else. mid-2010 iMac i7 8gigs ram
I am the same as Meus, Macbook pro. Wheel continues to turn... but is hung up. After click to start I have nothing.
Version 4243. Same problem. I'd really like to be able to play this game. This is incredibly frustrating and disappointing.
I'm not using Mavericks…still no answer and no replies.
No fix, No support, No help…but hey, now the game is OPEN BETA…maybe then we get heard?
I've got an early MacBook Pro (15-inch, early 2011).

Specs are:
Intel core i7, 2GHz, 8 GB RAM, Intel HD Graphics 3000 w/Radeon HD 6490M, 4 core, x64. OS X version is 10.9.1. I'm able to run it just fine in my Bootcamp/Win7 partition, but it just stays unresponsive on here after clicking 'Play'. I've left it alone for about 5 hours and when I come back it's exactly the same unresponsive status.
I also found that I'm getting the same things Jon said in his post.
I just found the logs folder. It's in ~/Library/Application Support/Battle.net/Logs/
In the folder I have a bunch of files, some starting with battle.net and some starting with libcef.
All of the libcef files have the same contents:
[1121/233749:ERROR:cef_context.cc(535)] No data resource available for id 4740
OK, I've found a solution for my issue.

Here's a summary of the problem I was encountering: installation of the game was fine, but in the Battle.net launcher, whenever I tried to click on the "Play" button for Hearthstone, the Hearthstone icon would appear in the dock, and the Hearthstone menu would appear at the top of the screen, but no window of the game would come up. Putting the mouse over the Hearthstone bar at the top, the cursor would turn into the spinning beachball of death.

So then on a hunch what I tried was to use the program "WhatsOpen" (search "WhatsOpen mac" on google for download link) to check the files that Hearthstone was accessing. The list was pretty ordinary except for one that caught my eye, "/Users/me/Library/Fonts/Gorilla.ttf", a font that I had installed a while ago. I removed the font and BAM! the game is working. It must have been corrupted font or something.

So you might want to try and see if there are any weird files that Hearthstone is accessing. Obviously this particular solution will probably only help those who've installed fonts, but it might be useful.
Jon!!!!!!!You are god damn right!!!! It also work for me!!!! Finally, I got the difference between my work server macPro and my macbook pro. I had installed some fonts when I just got this notebook. But I never used them after installation. I think this could be a general solution for this problem!!! Thanks Jon. I am looking forward for everyone's good news.
I just wanted to add that this solution works perfectly.
However you dont need to download Whatsopen.

You can just run Activity Monitor - then when Hearthstone hangs - it will say non responsive, double click and hit Open Files.

Scroll at the bottom it will list the TTF file.

However Note that you will need to keep on trying until it works.

It took me 3 different fonts deletion before the game runs.

Im running on a macbook pro 2012 with Maverick installed.
same problem, rebooted, reinstalled, issue repeats. anyone tried changing graphic settings? could be graphic related

Join the Conversation

Return to Forum