Battle.net app installation stuck on 65%

Mac Technical Support
I had the same issue. I started patching, let it sit for a few hours assuming it would be done. It was at 65% when I returned. All I did was restart the download and it worked the second time. If restarting doesn't work for you try letting it sit for a while and then restarting.
I have the same problem with my Imac

Intel Core i5

I want play but it is impossible with this error.
Okay this is bizarre just thought I'd share this. So was direct connected to my internet and tried to install the game and was constantly getting stuck at 65%. Went to the other side of my computer (its partitioned to have Windows 7) and downloaded and installed perfectly fine. Using the exact same internet connect. Okay, so then I went back to my mac side and I hooked up to my university's wi-fi and downloaded and installed perfectly fine. So I wonder what was wrong with my direct connection. I live in university dorms so I wonder if that has anything to do with it.
Same issue
Not the same issue, exactly, as the rest of you.

My installer was stuck at 65% because I had the WoW launcher open (patching) - closing it and relaunching setup worked wonderfully.
Same issue here, stuck at 65% despite restarting the installer and trying again.

Has there been no solution from support regarding this?
same issue, when are they fixing this problem? or is there an alternative download somewhere?
Had the same problem, but just after some attempt (click cancel and try to reinstall) it download all data and the installation finish.
It seems like blizzard's servers are to busy
Guys, you are not gonna believe this but this worked for me:

When asked to download the client from the page notice the language: in my case the file was hearthstone_somethingptPT.exe.

I downloaded the Us client after trying ALL the solutions because I thought "they must update it first"... and IT WORKED!

So if anyone here is trying to install their client from other language that is not US let me know.
stuck at 67% :(
I realize that this thread is old, but I am curious if the change to a case-insensitive file system fixed your problem?
Im having the same exact issue currently and still cant download hearthstone and im getting rather annoyed as ive spent 150$ on my deck
Old thread but still relevant today:
If your Mac file system is case-sensitive, the installation probably won't work.

Check by going into "Disk Utility". If "Format: " at the bottom of the window contains "Case sensitive", then you're probably screwed. You can change this, but it'll require reformatting :/

Hopefully Blizzard will fix this, but I wouldn't really count on it, considering (AFAIK) Diablo 3 still can't be installed on case-sensitive file systems:
http://us.battle.net/d3/en/forum/topic/5149145005

But you can always use Boot Camp and play it on Windows! Works well on my Mac Air (2011).
Not sure if this will help anyone but I am running A Macbook Pro and I had the issue where it would jump from 65% to 83%. Tried everything to get it to install however,

The thing that worked for me was to create a folder in applications and install it there and it worked first time!

So when the installer gives you the opportunity to change the location of the install, just throw up a new folder and see what happens !
I had the same problem.

All worked after i did this :

https://us.battle.net/support/en/article/disabling-proxy-settings

Hope it will help.
^^ Worked for me
Problem still persists. First I installed the battle.net agent and tried to install my newly acquired Diablo III, and it got stuck at the "initializing" stage. Twice. Following forum advices, I uninstalled battle.net and deleted the folder completely, then attempted to install the battle.net agent again and this time it was it that got stuck at 78%. I'm not a MAC user, though, I'm on a 4GHz quadcore 4GB RAM PC (pretty old now, however, way above system requirements). Just so you know that the issue concerns both platforms.
Same Problem... anybody found a fix yet?
Lisey post worked for me as well
I found an issue :
1/ launch the agent with your local parameters (in command) C:\ProgramData\Battle.net\Agent\Agent.exe --locale=frFR

2/ launch your game directly (Hearstaone, starcraft, etc ...)

Join the Conversation

Return to Forum