Play button greyed out.

Mac Technical Support
cannot click on Play button. I was played yesterday. Don't know what to do, have tried reboot mac, reinstalled battle.net.

Doesn't work
This is happening to me as well. I just got the beta today, installed it and the play button is grayed out saying, "service is unavailable in your region" but I'm In US, so I'm not sure whats wrong. Hopefully they fix it because I'm so disappointed I finally got the beta but can not play :(.
I am having this same problem as well. It won't let me connect to Battle.net through the Beta Launcher; but I can connect to bnet online and on other games.
same issue...pls help
I have been reinstalling battlenet and hearthstone everyday for 3 days now. All my other games are launching without any issues. Mac is up to date. Any help would be greatly appreciated.
I was having this problem for a sec and then realized I was trying to login with my Battletag rather than my email address! As soon as it detected an @ sign in the username field the blue button lit up. Worked for me, hope it helps anyone else having a PEBKAC error ;)
Started getting this even when i try and play Diablo 2 it says you have been disconnected by battlenet, PC though not MAC

Join the Conversation

Return to Forum