Hearthstone / Battle.net Agent Stuck

Mac Technical Support
Since I have received a Hearthstone Beta Key, I wanted to install the game.
I loaded the Battle.net Beta App and tried to install it but the install screen just freezes and does nothing. I tried letting it sit for 10+ hours and there was no progress.

Then I decided I would try the old way of installing just by clicking the Setup file on Hearthstone. Well another problem occurred by the Agent Update just freezing after an few minutes of "installing."

Example: http://imgur.com/UZIu3Ze

I thought it just froze, so I left it be for another 10+ hours and not even a budge.

With the game not installing through the beta app or the setup file I tried uninstalling the Beta App, and re-installing it. After that process nothing still has changed.

Any workarounds?
Thanks to the user, RvLeshrac #1237 reply on
http://us.battle.net/hearthstone/en/forum/topic/10262106975
Quote: "Deleting %ProgramData%\Battle.Net\Agent resolves the problem."
Resolved my issue.

Make sure you stall / stop all Battle.net Update Agent Update Processes and Battle.net App Processes to delete the file.

It will require another Agent Update once you restart the Battle.net App.
This fixed my problem. Thanks!
I would like to add:

Once you get through the install problem I also ran into a download problem with the game client (taking many hours to download .2 gigs of data with a 10 Mbps connection) and likely many others will as well.

The thread below fixed the problem and I downloaded the remaining data (over 75% of it) at my normal speed (about 30-40 minutes).

https://eu.battle.net/support/en/article/disabling-proxy-settings

Thanks again for the helpful thread!
THANK YOU kebbrokk ! That is the right directory to delete

Join the Conversation

Return to Forum