Installer Errors? This fix might work!

Technical Support
10/31/2013 03:50 PMPosted by LXX
Every time I try to delete the battle.net folder it says that it's open in another program. I made sure the app is closed and everything, but it still keeps saying it. Any ideas?


CTRL + ALT + Delete, end Agent.exe.
I have SC2 installed but haven't played for some months. These steps fixed the error in the Hearthstone installer. Thanks!
Bump, worked for me. thank you
usually it's the other way around and you just need to open another games launcher (D3, wow, Starcraft 2)
Bringing this to the front again. Not sure what happened, must have been a glitch or something because I just posted a few minutes ago :v.

Would be great if this could get a sticky. Lots of people seem to skim over this thread.
fixed my issue as well, thanks!
Glad it worked :)
I don't have any Blizzard game previously installed on this computer. I just got my Hearthstone beta key and I'd really like to install it. But it gets stuck on 64%. Any ideas how to fix this?
10/30/2013 12:59 PMPosted by Gerdalti
The following steps fixed my problem (NOTE: I received many different errors throughout this process so even if you don't have the same error, try this!)

-Delete the battle.net folder in %ProgramData%
-Should work!


Worked for me, thanks!


You're my hero
i am pretty sure i did all of them but it did not work. It stops on installing battle.net in 65%.
Can someone help me please, thanks

Join the Conversation

Return to Forum