Battle.net Agent / Hearthstone problems

Technical Support
Well, basically my agent is stuck on update (34%). I tried every solution and suggestion I'd found by googling this problem, as in:
  • Running as administrator
  • Running not as administrator
  • Disabling antivirus programs
  • Creating another windows user and trying to update
  • Configuring proxy settings through IE/registry
The only thing that "helped" was running the Battle.net.exe itself. So I've got to Agent, installed Hearthstone, but when I click "Play" I get BLZBNTAGT00000843 exception. Tried to reinstall it but didn't help.
Does it have anything to do with my Battle.net Agent version (that is apparently low since the update is necessary)? Can you give me files that were changed in the last update directly? Like, put all the \Program Data\Battle.net\, \Program Data\Blizzard\ and \Program Files\Battle.net\ into an archive and uploading it to some file hoster? My current versions are 1.0.6.4047 for Battle.net and 1.10.2.2514 for Agent.
Or any other solutions?
P.S. Posted this already on EU forums, if EU tech supports = US ones then I'm sorry for doubling, but I'm kind of desperate now. I'll request closing here if I'll get my answer there.
Hey mate,

Have you tried deleting the battle.net and Blizzard Entertainment cache folders? This normally fixes the issue. You can see how here: https://eu.battle.net/support/en/article/deleting-the-battlenet-cache-folder-windows
________________________________________________
Twitter: @Narull | ANZ Diablo III MVP
http://www.blizzposts.com - Keep track of all Official Blizzard posts.
There not spelling mistakes, Im speaking 'Ye Old English'
Yes, tried both deleting \Program Data\Battle.net\ and \Program Data\Blizzard Entertainment\, didn't help.
Needs a bump apparently.
Gonna bump because I'm still waiting on a solution for this since about the end of November. It's ridiculous - there's no real solution anywhere.
Bump
Marked As Solution
12/21/2013 03:30 AMPosted by Starcanum
Disabling antivirus programs

I'd go a step further, and use one of these removal tools for the antivirus program. That will be just a temporary test. Then I'd try installing the Battle.net app, and reinstall the antivirus program afterwards.
________________________________________________
Rate me! https://www.surveymonkey.com/s/Velnrak
Bump
I'd go a step further, and use one of [url="http://kb.eset.com/esetkb/index?page=content&id=SOLN146"]these removal tools for the antivirus program[/url]. That will be just a temporary test. Then I'd try installing the [url="https://us.battle.net/account/download/?show=bnetapp"]Battle.net app[/url], and reinstall the antivirus program afterwards.

Hell yeah, I love you. This did work.
Maybe someone should sticky this topic so that it'd be easier to seek for a solution. It's a common error so seems to be pretty useful as it contains pretty much all the possible ways to solve it.

Join the Conversation

Return to Forum