Mac texts/numbers graphic bug.

Bug Report
Hello all, sorry for my english.

I have older Mac (mini intel core duo 2). The game run very well in low, middle or high resolution. But I have a big unplayable graphic bug. All numbers card and 90% text in game dont rendering…
http://hamed.masson.free.fr/bugfontHS.jpg

I now this bug is on PC too… maybe older with old graphic card.

Hope will be resolve quick, like I say game really run good with old computer; and I now Blizzard doing game for the most of gamers and "low" config too.

Thx.
i got exact the same problem. before the 4217 patch came out everything was fine, but since that patch i cant play no more because of unreadable text all over in the game, patch 4243 didnt fixed this, now i wonder if there every will be a solution for this ... to be honest i already lost all hope to ever play this nice game again on my mac
.. days go by and still no solution to fix this rendering issue with the text. a statement from a blizzard emp. would be great if there will be a patch in the future to fix this otherwise i give up to ever play this game again on my mac and will uninstall it
same problem here
How many threads do we need to post on the issue to get some help?
Hoped recent patch fixed it, it didn't. I am on an older MacBook Intel CoreDuo. I can run the game, looks good, runs smoothly, I have good sound, and can see some words, but no notifications, or my battle.net id, or stats on cards.
my game does exactly the same thing i just installed it and went to play when this happens.
This. It worked initially, but then, couple of patches ago they broke it. And still - no fix, no info.
http://imgur.com/cNHTVl5
I'm having the same issue on a macbook 2007 w 2gb ram, 2ghz processor, and intel gma 950 graphics chip running on osx 10.6.8.

I realize the game won't run optimally on my machine, but I've played a few games and it runs slowly but otherwise ok, except for the inability to read anything off cards, mana, life totals, etc. Which is kind of crucial..

Hope someone can come up with a solution.
same here
same here, old macbook, only the texts that are fonts are unseen.
I have the exact same problem
What OS X version is everyone running? Any specs about your computer would be extremely helpful. I.E. Macbook Pro OS X 10.9.2 ect. ect.
Same Issue here. The Game runs smoothly, only text and numbers in the "Belwe Bd BT" font are not readable. I checked whether the fonts0.unity3d file was in place and it is.

Macbook OS X Lion (10.7.5) 2Ghz Intel Core 2 Duo, 4GB RAM, Intel GMA 950 Graphics with (only) 64 MB.

(The best fix I could think of would be to replace the current fonts0.unity3d file with one that worked in the past. Does anyone know where that could still be found?)
Same problem here, on a Macbook OS X 10.6.8
ditto
Same problem.

I'm running a old mac dualcore.

The font is there, but it is only 8kb in size.
I was told to make a new thread but I will add to this one, I'm having this exact issue. Black Macbook running latest 10.7 . Runs the game just fine just cant see any text.
Also just to keep the info flowing, I did a complete wipe of the system just to see if it would make any difference and it did not. This worked just fine a patch ago. Really frustrating!

Join the Conversation

Return to Forum